Is there any way I can speed up Visual Studio 2017's autocomplete suggestions / Intellisense?

Ken N 1 Reputation point
2021-10-06T04:41:15.837+00:00

Hello. My VS2017 has been very slow lately. I can type faster than it can suggest a lot of the time, and sometimes it's just p a i n f u l. Check out this video I recorded: https://www.youtube.com/watch?v=DL5dwqzd4Oo Before I realized I can't do Math.Ceiling on an integer, heh, I typed out Math.cei and it took a long time to bring up "Ceiling". Then in the next clip that follows, I changed List to SortedList to cause an error. Look how terribly long it took to go from typing Sorted to it being underlined as an error.

I'm not running a potato either, lol. It's an older system, but I think it should be plenty fast for an IDE. It's a Core i7-7700K overclocked to 5.2 GHz, water cooled, 32 GB DDR4-3200, GTX1080, and the OS and Visual Studio is loaded on an M.2 NVMe SSD:
XxSnTU2.png

I should think with those specs I wouldn't be seeing such painfully slow responses. I tried upgrading to VS2019, but that was a hot mess; it made this seem fast by comparison lol. Any ideas on how to optimize the IDE to speed that up? Thanks!

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
4,574 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Anna Xiu-MSFT 25,381 Reputation points Microsoft Vendor
    2021-10-07T02:48:02.487+00:00

    Hi @Ken N ,

    Welcome to Microsoft Q&A!

    Have you installed any extensions that are slowing Visual Studio down? You can temporarily disable them under Tools > Extensions and Updates > Installed.

    Meanwhile, please free up your disk space and ensure enough memory is available. You can clean the %temp% folder and delete the hidden .vs folder in the project folder.

    Besides, if you have hardware acceleration enabled, or if you use the default visual experience settings in Visual Studio 2017, you may experience intermittent performance issues, product crashes, or rendering issues. You can uncheck Automatically adjust visual experience based on client performance check box by Tools > Options > Environment > General.

    Sincerely,
    Anna
    *
    If the answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments