After moving web app from http to https email-tasks cannot be opened.

Oleg Tserkovnyuk 586 Reputation points
2021-10-06T12:30:53.463+00:00

Hello,

I have migrated the web application http://test.company.com from SP2013 to SP2019. On the SP2019 I have created this web app with SSL, so the URL is httpS://test.company.com. On the SP2019 I have installed the URL rewrite module and configured HTTP>HTTPS redirect as described here https://www.sharepointdiary.com/2015/02/redirect-http-to-https-in-sharepoint-2013.html![138129-e0.jpg][1]. It works fine in all cases except one. WF tasks (out of box approval WF) which were initiated on the SP2013 cannot be opened from Outlook on the SP2019. I have tried the same migration but from HTTP 2013 to HTTP 2019, everything worked without issues. Obviously the problem is related to adding SSL on the SP2019.
If I point test.company.com to SP2013 (no SSL), I can open a task from Outlook. Clicking on the 'Open this task' opens a new tab in the browser with the task. If I copy the URL, point test.company.com back to SP2019 (SSL) and open this URL, redirects works fine. Basically, redirect does not work only when I open a task from Outlook.
On the SP2019 I have one AAM for the web app: httpS://test.company.com. Tried to add additional internal default AAM http://test.company.com , but this did not change behavior.
WF tasks created on the migrated version (SP2019 SSL) can be opened in the Outlook without any issues. Is it expected behavior or I missed something when configured HTTP>HTTPS redirect?

I have attached screenshot with the error I get in the Outlook when open task on the migrated version of the site. Task was created on the SP2013.

SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,897 questions
0 comments No comments
{count} votes

Accepted answer
  1. Oleg Tserkovnyuk 586 Reputation points
    2021-12-14T12:30:59.783+00:00

    MS provided response:
    The Outlook client does not handle 301 HTTP redirect responses.
    This is a limitation in the design of the product.

    As an alternative I suggest following:

    1. You can do 2 things together to resolve this: you can update the redirect rule so that it does not apply to Outlook client requests (by filtering by user agent) but at the same time you need to make sure that SharePoint responds to HTTP requests and for that you need to extend the SharePoint web application to the URL that the Outlook client expects (HTTP)
    2. From a SharePoint perspective opening the tasks in the browser will work just fine and users can be educated to use the browser interface
    0 comments No comments

2 additional answers

Sort by: Most helpful
  1. Emily Du-MSFT 44,151 Reputation points Microsoft Vendor
    2021-10-07T03:07:25.767+00:00

    @Oleg Tserkovnyuk

    It may be caused by that even if the URL rewrite module is installed, http will not be redirected to https in the Outlook.

    You could try to add both http and https URL in the trusted sites then have a test.

    And please go to ULS logs and Fiddler to find more clues.


    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. Oleg Tserkovnyuk 586 Reputation points
    2021-10-08T12:41:34.05+00:00

    Thanks for response. I have added both http and https version to trusts sites, this did not help. ULS logs are clear. Unfortunately I cannot use fiddler due to vpn solution which I use. Opened case with MS.