MSIX packages with AADDS and Azure Files

Florian Eber 21 Reputation points
2021-10-07T08:40:26.14+00:00

Hello,

i tried to add a msix package to a host pool in my azure virtual desktop. The package is located in Azure Files and permission for the session host and user is set.
The Azure Files are connected to my Azure Active Directory Domain Service and also to the virtual machines.

138463-microsoftteams-image-10.png

When i try to add the path of the msix package from my file share, i get an error.

138492-microsoftteams-image-12.png

Is it even possible to add a msix package to a AADDS or is it only with normal AAD possible?

Azure Storage Accounts
Azure Storage Accounts
Globally unique resources that provide access to data management services and serve as the parent namespace for the services.
2,898 questions
Active Directory
Active Directory
A set of directory-based technologies included in Windows Server.
6,202 questions
Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
20,482 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Limitless Technology 39,506 Reputation points
    2021-10-07T18:20:19.717+00:00

    Hello @Florian Eber

    Have you tried putting the VHD on a different drive, for example C drive? I believe it was not recommended to manually add files into the VHD that are not part of the MSIX, That breaks the validity of the MSIX package and we will report no valid MSIX is present. I would recommend that on 1 of your machines you create a c:\share folder. Share it to everyone (read) put the package there and pass the path \shares\<name of msix image>

    Hope this helps with your query,


    --If the reply is helpful, please Upvote and Accept as answer--

    0 comments No comments

  2. Tom Mason 6 Reputation points
    2022-06-29T22:59:11.357+00:00

    https://learn.microsoft.com/en-us/azure/virtual-desktop/app-attach-faq

    "Can I use Azure Active Directory Domain Services (Azure AD DS) with MSIX app attach?
    MSIX app attach doesn't currently support Azure AD DS. Because Azure AD DS computer objects aren't synchronized to Azure Active Directory (Azure AD), the administrator can't provide the required role-based access control (RBAC) permissions for Azure Files."

    0 comments No comments