"Your Outlook data file cannot be configured" for domain users with roaming profiles on a PC they have not used before.

Simon 11 Reputation points
2021-10-07T13:12:52.35+00:00

I have seen a lot of post on this error message but not found any with the same situation as me. I can see exactly why it is happening but can't find a fix.

I have recently changed our internal domain name and since then I've enabled cached Exchange mode for all users. When logging into a PC they have used before the domain change it creates the local copy of their profile in "c:\Users\username.domain" since "c:\Users\username" already exists. This makes the path for the local OST file "c:\Users\username.domain\Local\Microsoft\Outlook\username@keyman .co.uk.ost".

That all works fine until they log into a PC they did not use before the upgrade. Since there is no existing old local profile folder the new one is created as "c:\Users\username" (without the domain). This is all normal behavior for roaming profiles. However when trying to open Outlook for some reason it still expects the OST file to be in "c:\Users\username.domain\Local\Microsoft\Outlook\username@keyman .co.uk.ost" which of course does not exist!

Most suggested solutions involve repairing the file or deleting it so it can be recreated but of course since the folder doesn't even exist none of these solutions apply.

What I need is for Outlook to use "%appdata%\Microsoft\Outlook" as the folder location but when I enter that it immediately "corrects" it to the full path.

Outlook Management
Outlook Management
Outlook: A family of Microsoft email and calendar products.Management: The act or process of organizing, handling, directing or controlling something.
5,054 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. ChristyZhang-MSFT 22,081 Reputation points Microsoft Vendor
    2021-10-08T03:01:44.193+00:00

    Hi @Simon ,

    Welcome to our forum!

    That all works fine until they log into a PC they did not use before the upgrade.

    You mean that the account after the domain name change can run normally on the PC that has not logged in before the change, right?

    If so, I think it is related to the roaming profile. It is suggested that you could add your accounts in a new profile and remember to disable the Exchange mode:

    1. Control panel>Mail>Show Profiles…>Add…>type the name of your new profile>click OK;
    2. Choose Email Account, and fill in the related information about your account>click Next;
    3. After your email account is successfully configured, select Change account settings and click Next;
      138718-3.png
    4. Under Offline Settings, uncheck Use Cached Exchange Mode>click Finish;
      138719-4.png
    5. Back to Mail window, choose Prompt for a profile to be used.
    6. Restart the Outlook.

    If it still doesn't work, please try to remove the old profile in control panel and check if there're any differences.


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.