Error launching executable: "The requested operation requires elevation"

Elroy 11 Reputation points
2021-10-08T20:12:40.127+00:00

We're running 32-bit Windows 10 build 1909 on some of our test computers. When we launch an application that was developed in-house, we see an error message, "The requested operation requires elevation".

We're logged-in with administrative context and we have tried taking ownership of our application folder & files. We still see the prompt when we double-click the shortcut or executable.

We have tried turning-off UAC, that didn't help.

If we Right-click the shortcut and click "Run as administrator" the application works properly.

The problem is that we need this application to run for standard (non-admin) users. What do we need to change to make the "elevation required" message stop?

Thanks for reading!

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
11,152 questions
Windows 10 Security
Windows 10 Security
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Security: The precautions taken to guard against crime, attack, sabotage, espionage, or another threat.
2,837 questions
0 comments No comments
{count} votes

5 answers

Sort by: Most helpful
  1. Michael Taylor 51,016 Reputation points
    2021-10-08T20:47:47.603+00:00

    Couple of things that could cause this beyond what you already mentioned.

    • Does the application have a manifest file that specifies it requires elevation? If so then adjust or remove the manifest file from your project and rebuild.
    • Is it running in compatibility mode? If so then remove the compatibility settings on the exe/shortcut.
    • Is the exe/shortcut properties configured to require an administrator? If so then remove that setting from the exe/shortcut.
    1 person found this answer helpful.
    0 comments No comments

  2. Elroy 11 Reputation points
    2021-10-08T20:54:07.993+00:00

    Thanks for your reply! It is not running in compatibility mode, I know we checked that... I don't believe that the file/shortcut properties are configured to require an administrator, we checked properties and I don't recall seeing anything like that but I will re-check.

    I will check with the developer to see whether there is a manifest file.

    0 comments No comments

  3. MotoX80 32,736 Reputation points
    2021-10-09T12:07:03.037+00:00

    What IDE/compiler is he using? I would expect there to be an elevation setting in the project settings.

    What API calls is his code making? Is he doing something that requires admin access?

    0 comments No comments

  4. Limitless Technology 39,496 Reputation points
    2021-10-13T08:19:02.66+00:00

    Hi there,

    When Windows can't recognize the security identifier associated with the file ACLs (Access Control List / Permissions) it displays the SID. Normally Windows will be able to translate that SID into an account name or alias, such as 'DOMAIN\Username'. So makes sure that your exe file can fetch the required details from the Users or the app manifesto.


    If the reply is helpful, please Upvote and Accept it as an answer

    0 comments No comments

  5. Igor 1 Reputation point
    2021-10-25T15:11:36.75+00:00

    Hello, I work with Elroy-1144. Thank you everyone for your suggestions. I ended up doing what @Michael Taylor suggested but in reverse. Our application did not use a manifest file. After adding this file and rebuilding this C# app using VS2019 it solved the issue. The small shield right above the .exe app that was visible on some of the racks is no longer there. This is still strange since this issue was only happening on some racks.

    On 32bit machines we are still not able to see compatibility tab when right clicking on the app and going to properties. Would anyone know why this might be happening?

    Thanks.