question

RalphWestland-5653 avatar image
0 Votes"
RalphWestland-5653 asked RitaHu-MSFT commented

WSUS post install failed on 2016 Essential server DC

After run post install for WSUS on a Server essential 2016 DC server we receive database errors:
ClientConnectionId:ef156204-4956-4309-8cd4-0b7d2c353c62
Error Number:3605,State:1,Class:16
Fatal Error: Schema verification failed for database ‘SUSDB’.
ALTER DATABASE statement failed.
Failed to restart the current database. The current database is switched to master.

SQL query to set database to Master is failed with same error

I removed WSUS, reboot server, Removed WID en reboot server.
Removed all folders of WSUS en WID
Framework 4.7 is not installed
Reinstalled WID en reboot server
Installed WSUS en reboot server
Run post install task en receive the database error

On server server 2016 DC it is running without any problems, only this server give troubles.

windows-server-update-services
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

RitaHu-MSFT avatar image
0 Votes"
RitaHu-MSFT answered RitaHu-MSFT edited

Hello,

Thanks for your posting on Q&A.

Please follow the below steps one by one to remove the WSUS completely. There will be something wrong to reinstall the WSUS role if we haven't remove complete:

To remove WSUS completely, you need to:
1. Remove the following server roles and features through Server Manager:

Roles: Windows Server Update Server

features: Windows Server Update Services Tools(at Remote Server Administration Tools -> Role Administration Tools)

Follow the wizard prompts to complete the deletion. Then restart the server.
2. After the server is restarted, manually delete the folder or file of the following path:

C:\WSUS (this depends on where you choose to install WSUS)

C:\Program Files\Update Services
3. Delete database files

If you use SQL Server Management Studio to delete a database, you can try as follow.

In Object Explorer, connect to an instance of the SQL Server Database Engine, and then expand that instance. Expand Databases, right-click the database to delete, and then click Delete. Confirm the correct database is selected, and then click OK.

If you use a WID database, it is recommended to delete the following path folders:

C:\Windows\WID
4. In the IIS Information Services (IIS) Manager, manually remove the WSUS Administration site. Then restart the server.

Or, you can also consider using the Powershell command Remove-WebSite -Name "WSUS Administration" for deletion.

Please follow the above steps one more time and reinstall the WSUS role. Please share the error logs with us if the issue stays.

Hope the above will be helpful.

Regards,
Rita


If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

RalphWestland-5653 avatar image
0 Votes"
RalphWestland-5653 answered RitaHu-MSFT edited

This installation140803-tmp1f70.txt removal was done several times but still the error as seen in the attached log



tmp1f70.txt (57.2 KiB)
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

What is the type of the database? Have you installed the SSMS on your WSUS server?

It seems that the issue is more related with database. Please try the following steps to confirm whether the issue will be resolved or not.
1) Stop the WSUS Administrator Website in IIS
2) Remove the WSUS Administration website from IIS
3) Remove the WsusPool under Application Pools in IIS
4) If using Widows Internal Database (WID) connect to the local server: \\.\pipe\MICROSOFT##WID\tsql\query and delete the SUSDB from there
141214-4.png

Then we could try to reinstall the WSUS role. Note that the below files have to been removed before reinstalling the WSUS role:
C:\WSUS (this depends on where you choose to install WSUS)
C:\Program Files\Update Services
Database files

Regards,
Rita

0 Votes 0 ·
4.png (14.7 KiB)
RalphWestland-5653 avatar image
0 Votes"
RalphWestland-5653 answered RitaHu-MSFT commented

SMSS version 2016 is installed on the server.
We use the WID database

Databse deleted, WSUS removed, server reboot.
WID removed en server reboot
Folders Windows\wid removed and program files\update server removed.

Clean install WID and reboot
Clean install WSUS and reboot
Post install via powershell.
Error :
Fatal Error: Schema verification failed for database ‘SUSDB’.
ALTER DATABASE statement failed.
Failed to restart the current database. The current database is switched to master.

Via SQL query try to set SUSDB database to multi user, failed

It seems to be a WID problem

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@RalphWestland-5653
I haven't encountered this issue before and there is no such lab environment for test. But I found a related link. It seems that a lot of people resolved this issue by running the wsusutil.exe postinstall /servicing command. Please try to run this command in your environment and confirm whether this issue will be resolved or not if you haven't tried before.

Hope the above will be helpful.

Regards,
Rita

0 Votes 0 ·