question

RobvanHouten-1844 avatar image
0 Votes"
RobvanHouten-1844 asked KaelYao-MSFT commented

Moving an appointment in Exchange 2016 owa calendar changes Time Zone

L.S.,

A couple of our users complained that some of the recepients of the appointments they made in teams received them with a time that was two hours off. After extensive testing, I did find a problem, which I have been unable to fix.
All ics files which are send have a TZID:W. Europe Standard Time, which the external recipients have no problem with, but if they move the appointment in the webmail owa, this changes automatically to UTC. I don't see any option to stop exchange from changing the timezone. If they move an appointment in Outlook or Teams, the timezone stays as Western European Standard Time. Is there any way to keep Exchange from making this change?

With Regards,

Rob van Houten

office-exchange-server-administration
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

KaelYao-MSFT avatar image
0 Votes"
KaelYao-MSFT answered KaelYao-MSFT commented

Hi Rob.

Did you mean if changing the time of an appointment in OWA, it would cause a two hours delay to the actual time.
If it is the case, since OWA would use the time zone setting of the mailbox, please run this command in Exchange Management Shell to have a check if the time zone of the mailbox is the same as the current zone time of the affected users.

 Get-mailboxregionalconfiguration -identity <user mailbox>

If the time zone isn't Western European Standard Time, please run this command to change it and see if it can get rid of this issue:

 Set-mailboxregionalconfiguration -identity <user mailbox> -timezone "W. Europe Standard Time"

If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

The problem is that the owa isn't using the timezone of the mailbox of the exchange server, and in the ecp I don't see it displayed that way. So running the Get-mailbox regional configuration it returns W. Europe Standard Time, and the appointments are made in Western European standard time,
but in the ecp the timezone is displayed as UTC+1, with the only option to choose from UTC settings, not Western European standard time.
The result is that if they create or move an appointment in OWA, the server sends out ics files with different timezones.

ICS from outlook gives:

BEGIN:VCALENDAR
METHOD:REQUEST
PRODID:Microsoft Exchange Server 2010
VERSION:2.0
BEGIN:VTIMEZONE
TZID:W. Europe Standard Time

ICS from webmail OWA gives:

BEGIN:VCALENDAR
METHOD:REQUEST
PRODID:Microsoft Exchange Server 2010
VERSION:2.0
BEGIN:VTIMEZONE
TZID:(UTC+01:00) Amsterdam\, Berlijn\, Bern\, Rome\, Stockholm\, Wenen

So I would like to set the timezone for the webmail/owa also to Western European Time, the same as for outlook and teams, but I can't find that option.

0 Votes 0 ·

Thanks for the information!

While I suppose this issue may possibly be caused by the jet lag between Western European Time and Western European Time and Western European Summer Time.

So I would like to set the timezone for the webmail/owa also to Western European Time, the same as for outlook and teams, but I can't find that option.

In OWA there isn't an option to change the timezone for meetings like in Outlook or Teams, by default OWA would use the timezone setting of the mailbox.
In this case, it should be (UTC+01:00) Amsterdam\, Berlijn\, Bern\, Rome\, Stockholm\, Wenen.

You may need to adjust the timezone of OWA to be the same as the actual timezone you are using.
Here is a link for the steps: Change the time zone and language settings in Outlook on the web


0 Votes 0 ·
RobvanHouten-1844 avatar image
0 Votes"
RobvanHouten-1844 answered KaelYao-MSFT commented

That is the timezone which is shown. The problem seems to be that the ics which is send is different depending on whether you change or make it in the owa or Exchange. So i basically have to tell my users to warn the external contacts they have with this problem that the time is two hours off, and put the exact time in the meeting description?

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

That is the timezone which is shown.

Yes. It shows "W. Europe Standard Time" in EMS.
However, the actual time zone Exchange currently using is (UTC+01:00) Amsterdam\, Berlijn\, Bern\, Rome\, Stockholm\, Wenen.
It is the same as you mentioned in your former reply:
but in the ecp the timezone is displayed as UTC+1, with the only option to choose from UTC settings, not Western European standard time.

When you make changes to appointments in OWA, it would use this time zone (UTC+01:00).

If you manually adjust this time zone setting in OWA to match the time zone of yours, Exchange would use the correct time zone instead.

0 Votes 0 ·

Hi @RobvanHouten-1844

I am writing here to confirm with you how thing going now?
If you have any questions or needed further help on this issue, please feel free to post back.

0 Votes 0 ·
RobvanHouten-1844 avatar image
1 Vote"
RobvanHouten-1844 answered KaelYao-MSFT commented

The problem exists, even with the timezones set correctly. I will close it, but the problem hasn't been solved. It is strange that moving an appointment in outlook or webmail creates a different ICS header, which some external mailservers are not capable of handling. So I will warn my users not to use webmail to create or change their appointments.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Sorry for the inconvenience.

If you have other questions, please feel free to post on our forum.

0 Votes 0 ·