Universal Print: Unable to connect via Connect-UPService

Kevin Eberhard 1 Reputation point

Hello together,

our business is using an Azure tenant for User management. We still have some ressources in an onPrem AD environment, connected to Azure via AD Connect.

To test the Universal Print feature, I installed the UP Connector on one of our onPrem Domain Controllers since we don't have a dedicated Print Server.
I logged in, added the DC as UPC and added some printers. I then checked Azure Portal/Universal Print for the UPC i just created, created a Printer share and tested cloud printing. Everything worked just fine.

When I was trying to remove the UPC, I followed these steps:

  • removed all Printer shares via Azure Portal/Universal Print
  • unregistered the printers I tested with
  • started an elevated PowerShell CLI on the DC with the UPC App
  • Installed the UniversalPrintManager Module
  • tried to Connect to UPService

That's where my issue comes up. When using the CMDlet "Connect-UPService", I get the following exception:

connect-upservice : Mindestens ein Fehler ist aufgetreten.Service is unavailable to process the request
In Zeile:1 Zeichen:1

  • connect-upservice -userprincipalname XXXX@XXXXXXXXXXXXXX.com
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  • CategoryInfo : Authentifizierungsfehler: (:) [Connect-UPService], FailedCmdletException
  • FullyQualifiedErrorId : Microsoft.UPManagement.Cmdlets.ConnectService

(translation of german bits: At least one error occured; authentication error)

The UPN I used is a Microsoft 365 E3-licensed Cloud Printing Administrator. The password I used is definitely correct. There should be no authentication error. I even tried an app password since I'm using 2FA for my UPN.

Does someone have a possible solution to this issue? Any help is much appreciated.

Best regards

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
23,993 questions
No comments
{count} votes