question

Office365Administrator-8330 avatar image
0 Votes"
Office365Administrator-8330 asked LuDaiMSFT-0289 commented

Why does my android continue asking me to set a longer device password?

I have removed the user and reset him up in the company portal. I continue to get a message "your company needs you to adjust these settings to comply with organizational policies. Set a longer device password, A device password must be at least 4 characters long. I have changed it and have done a resolve and it still does not work. It is an Android Samsung Galaxy S10e version 11 with the Knox version 3.7. Could you please help!

intune-device-configuration
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

LuDaiMSFT-0289 avatar image
0 Votes"
LuDaiMSFT-0289 answered LuDaiMSFT-0289 commented

@Office365Administrator-8330 Thanks for posting in our Q&A.

For this issue, it seems a known issue and others has fed back this issue. I will share you some information. This issue arose because of a new Company Portal update which was required due to Google's move to use API 30.

To fix this issue, it is suggested to edit to include one of the five configurations as needed in Android compliance policy and re-enroll to check if it is successful.
141858-image.png

For more detailed information about this issue, please read the description in the following picture:
141907-image.png

Hope it will help.


If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



image.png (50.5 KiB)
image.png (344.6 KiB)
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

This would work but when I click on Compliance Policies there are non. I did create one and added two groups to my policy. This still did not work. I did not set this up and am unsure as to how to get these to work. Any information would be great.

0 Votes 0 ·
LuDaiMSFT-0289 avatar image LuDaiMSFT-0289 Office365Administrator-8330 ·

@Office365Administrator-8330 Thanks for your update.

Please check if the target device which is applied the compliance policy shows "compliant" status. If yes, it means that the device successfully applied the device compliance policy settings.

And if the message about password still exists. With Q&A limitation, it is suggested to open a online support ticket to get the further help. It is free. Here is the support link:
https://docs.microsoft.com/en-us/mem/get-support

Hope it will help.

0 Votes 0 ·