question

RAVINDRAHravinh-0493 avatar image
0 Votes"
RAVINDRAHravinh-0493 asked PradeepKommaraju-MSFT answered

Managed disk successfully attached to VM but not mounted

Hi All,

I'm trying to create an instance of Cisco C8000V router VM instance in Azure and attach a 2TB data disk. Though both the VM creation and data disk attachment to the VM is successful I see that the volume is not getting mounted.

Below output shows that the volume has been attached to VM (lsblk command output).

[vm30:/]$ lsblk | grep 2T
sdc 8:32 0 2T 0 disk
`-sdc1 8:33 0 2T 0 part
[vm30:/]$

However, df -Th does not show this volume mounted.
[vm30:/]$ df -Th | grep 2T
[vm30:/]$

Please let me know what might be causing this issue and how to resolve the same.

Thanks & Regards,
-Ravi

azure-virtual-machinesazure-managed-disks
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

PradeepKommaraju-MSFT avatar image
1 Vote"
PradeepKommaraju-MSFT answered

Hi @RAVINDRAHravinh-0493 ,

Thanks for reaching out to Microsoft Q&A Platform .

Let me explain you the concept of attaching a data disk here ,This involved two steps :
1) Attaching the new data disk to the VM through portal/powershell/CLI/API .
2) Once the disk is attached we should manually log into the VM and either initialize or mount the disk .

Ref:
https://docs.microsoft.com/en-us/azure/virtual-machines/windows/attach-managed-disk-portal
https://docs.microsoft.com/en-us/azure/virtual-machines/linux/attach-disk-portal

So the question is did you try to mount the disk manually ?

Please do let me know if this answer is acceptable in your use case or do let me know if you have any further questions on the same .

Thanks and Regards ,
Pradeep

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.