Cannot delete backup vault

Itay Menashe 1 Reputation point

Hello all,

Im trying to delete the last resource in our Azure portal, but I got an error each time.

The error I got is :

Vault deletion error
Cannot delete the Backup vault as there are existing backup instances or backup policies in the vault.

I have no other resources under this account! I deleted them all.

Any ideas?

Azure Backup
Azure Backup
An Azure backup service that provides built-in management at scale.
779 questions
{count} votes

3 answers

Sort by: Most helpful
  1. SadiqhAhmed-MSFT 25,381 Reputation points Microsoft Employee

    @Itay Menashe Thank you for reaching out to us!

    The detailed process to delete Azure recovery service vault (RSV) is documented here -

    Deleting the backed up resources is not enough to delete RSV, you need to delete the underlying resources as well.

    Just wanted to specifically highlight on the process to delete MARS agent backup - the process is little different from other protected backup instances.

    Hope this helps. Let us know if you need further assistance in this matter!


    If the response helped, do "Accept Answer" and up-vote it

    No comments

  2. SUNOJ KUMAR YELURU 12,411 Reputation points MVP

    Hi @Itay Menashe

    You can't delete a vault that contains backup data in the soft deleted state.

    Recovery Services vault cannot be deleted as there are backup items in soft deleted state in the vault. The soft deleted items are permanently deleted after 14 days of delete operation.

    Disabling soft delete using Azure portal
    To disable soft delete, follow these steps:

    1. In the Azure portal, go to your vault, and then go to Settings -> Properties.
    2. In the properties pane, select Security Settings -> Update.
    3. In the security settings pane, under Soft Delete, select Disable.


    Disabling soft delete using Azure PowerShell

    If the Answer is helpful, please click Accept Answer and up-vote, so that it can help others in the community looking for help on similar topics.

    No comments

  3. Hugh Dyar 0 Reputation points

    For anyone else reading this, when you go to look for the policies and the identities that you can't delete - and it shows you none - click on the blue filter named "Datasource Type = ". The default view does not show all policies or identities.

    No comments