question

TricolorDango-8355 avatar image
0 Votes"
TricolorDango-8355 asked

ReFS strange corruption issue "The system cannot find the file specified"

Looks like I'm experiencing a file system corruption issue with ReFS.

Basic facts:

a. The file CAN be opened/read from software (Windows Photos/explorer/Notepad++) with NO problem.

b. You cannot move/delete the file from explorer/cmd. They complain they cannot find the file "The system cannot find the file specified". (The same thing happens if I boot windows into recover mode and use its Administrator Command Prompt)

c. The two drives that have this issue are ReFS 3.7 volumns on two different physical disks (One HDD, one SSD). One of them has Bitlocker the other one does not.

d. I'm running Windows 11 Enterprise Version 21H2 (OS Build 22000.282)

Video:

I cannot move the file:
https://youtu.be/xRy_tmucrro
The file also cannot be moved in CMD:
https://youtu.be/pQi8T0NWgdY

================

Things I tried:

e. As I mentioned, I experience the same behaviour from Windows' Recovery mode with only the command prompt.

f. I tried use refsutil.exe. It found some "cluster leaks" in these two drives and fixed them but the same issue persists.

g. refsutil.exe cannot run salvage because it claims it only supports ReFS 3.5 and mine is ReFS 3.7 (Looks like MSFT did not update utility along with its system). Tried -sv option but get the same version complaint.

===========

At this stage I'm out of ideas. Any input would be appreciated.

143202-recovery1.png


143185-recovery2-fixleak.png
143139-recovery3-salvage.png


windows-11
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

0 Answers