question

sns1 avatar image
0 Votes"
sns1 asked RaytheonXie-MSFT edited

While loading the debugging url

While loading the debug URL after running gulp serve coming up with following error![145191-error.png][1]
https://tenantname.sharepoint.com/sites/XXXSPFx/SitePages/CVD.aspx*?debug=true&noredir=true&debugManifestsFile=https://localhost:4321/temp/manifests.js*

Please help
[1]: /answers/storage/attachments/145191-error.png

office-sharepoint-onlinesharepoint-dev
error.png (37.4 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

RaytheonXie-MSFT avatar image
0 Votes"
RaytheonXie-MSFT answered RaytheonXie-MSFT edited

Hi @sns1 ,
Usually,we get the error message if we do not serve our solution using the gulp serve –nobrowser command or if we forgot to trust the self-signed certificate using the gulp trust-dev-cert command.
Please make sure if you have run these cmdlets.

 gulp trust-dev-cert
 gulp serve –nobrowse


If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.




· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi Raytheon Xie,
When we should run those commands. is it before running gulp serve? ( I have particular path in the command prompt, I should run it from same path from particular command prompt? )

0 Votes 0 ·

Hi @sns1 ,
The gulp trust-dev-cert should be executed before gulp serve. You can also start the local web server without launching a browser by including the nobrowser argument to the gulp serve command.

 gulp serve –nobrowse





0 Votes 0 ·