question

heavy-d avatar image
0 Votes"
heavy-d asked heavy-d commented

Exchagne 2019 Server for OWA and ECP Only

Since Exchange 2019 no longer has a dedicated CAS role like previous versions how could I go about setting up a server that just ran OWA and ECP access? I have an application that has to be installed on the server running OWA but can not be installed on the currently setup Exchange servers.
Thanks

office-exchange-server-administration
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

AndyDavid avatar image
0 Votes"
AndyDavid answered heavy-d commented

I would ask the application vendor or owner. If it cant be installed on Exch 2019 as it is now, you have three choices:

  1. Use Exch 2013 until further notice for this app ( 2013 out of mainstream support)

  2. The app creator needs to fix this so it runs on 2019.

  3. Find a different app







· 6
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

It can run on Exchange 2019, just not on one of the existing installs. There would be conflicts, that is why I need another install of Exchange 2019, but it only need to have OWA access interface.
Thanks

0 Votes 0 ·

Ok, then you should be ok the it sounds like :)
There is of course no way to separate the roles in 2019, so the new server can have a single database on with no user mailboxes.

Set the SCP and existing client URLs to the other mailbox servers that handle client requests.

https://www.mustbegeek.com/configure-external-and-internal-url-in-exchange-2016/

(applies to 2016/2019)

0 Votes 0 ·

Thanks for the quick answer. I will try it out tomorrow when I have more time.
Thanks again!

0 Votes 0 ·

Something odd happened. So my original servers are all behind a hardware load balancer. the new server I was going to use for OWA only has not been put into the load balancer at all and does not have any open ports for external access. Yet some users externally are making connections to the new server. It does not have any mailboxes on it at all, completely empty mailbox database. How can I prevent users from using the new server at all?
Thanks

0 Votes 0 ·

Yea, that was from my previous comment:
Set the SCP and existing client URLs to the other mailbox servers that handle client requests.
https://www.mustbegeek.com/configure-external-and-internal-url-in-exchange-2016



Set these values to the load balancer values on the new server so clients will connect to the servers in the load balancing pool and not the new server

In other words, these URLS and SCP for autodiscover should all match on every server - even the server not in the load balanced pool.

See all 8 steps in that doc

0 Votes 0 ·
Show more comments