Can't add custom domain to App Service ending with Top Level Domain '.ad'

asked 2021-11-03T12:07:51.217+00:00
Christian 1 Reputation point

Hi,

In the past few days, I have tried to add a custom domain to an App Service in Azure ending with top level domain '.ad'. The DNS has been configurated correctly by creating TXT and CNAME entries.

When I am trying to add the custom domain, the system validates it correctly but when I click 'Add custom domain' it fails. The only explication I may think of is that Azure still doesn't support top level domain ending with '.ad'.

I hope you can help me with this. Thanks.

146177-captura.png

146187-captura1.png

Azure Web Apps
Azure Web Apps
A feature of Azure App Service used to create and deploy scalable, mission-critical web apps.
4,307 questions
No comments
{count} votes

1 answer

Sort by: Most helpful
  1. answered 2021-11-05T02:32:05.877+00:00
    Ryan Hill 15,991 Reputation points Microsoft Employee

    There shouldn't be any issue with add .ad domains if it wasn't purchased from Azure. There is a list of supported App Service domains but I don't think this applies to you. The following detectors under App Service Diagnose and solve problems blade that may help clarify the issue:

    • Run All Certificate & Domain checks
    • ARM - Certs and Domains
    • Check Geo Migration

    You can also use F12 from the portal or use the following CLI command to see what's causing the error message:

       az webapp config hostname add --hostname cname.mycustomdomain.ad --resource-group MyResourceGroup --webapp-name MyWebapp --debug  
    

    ---
    UPDATE:

    I've determined that not being able to .ad domains is a known issue. The best way to work around this issue is to use the Azure Resource Explorer to update the binding.

    • Expand + subscriptions
    • Scroll down to the subscription with the target app service and expand + <Subscription Name>
    • Expand + resourceGroups
    • Scroll down to the resource group of the target app service and expand + <Resource Group Name>
    • Expand + providers
    • Expand + Microsoft.Web
    • Expand + sites
    • Under hostNames, add your domain.
    • Click the green PUT button

    It should look like the image below.

    162578-image.png