Problems accessing Azure Portal

asked 2021-11-10T20:34:43.693+00:00
Zurab Sajaia 1 Reputation point

Hi,

I've been having a strange issue and I not able to figure out what is going on.
Here are the facts:

  1. I have a work account as well as personal microsoft accounts.
  2. Using work account I had some activity on azure and devops.
  3. Later, our IT restricted access to the azure and certain other MS services at work, so if I try to access portal.azure.com on my work machine, using my work account, I get a (customized) error that, although login was successful, my account doesn't have access to the resource.
    3.1. I had tried to access the same service on my personal computer (but with the work credentials) and go the same error.
  4. now I'm trying to access portal.azure.com with my personal account (hotmail.com) on my personal device, so this has absolutely no relation with my work, but somehow I'm getting the same error (with the same work custom page) that login (with my hotmail email) was successful but I don't have access to the resource.

I tried clearing browser caches (happens on multiple browsers), doing 'deep' logout with https://aka.ms/vssignout . I'm managing to get access to the personal devops area on dev.azure.com but still cannot access azure portal.

There are no personal certificates installed as far as I was able to find, nothing in browser memory is there, so must be something 'memorized' on the remote/account side.
So the question is, what am I doing wrong or what other kind of 'logoff' I need to perform to make my personal computer forget about the work account?

As I said, although I'm able to login to dev.azure.com with my personal account, but it is strange that when clicking on 'switch AD' I see my work AD listed as an option, so something is still associated with my personal computer...

Azure Active Directory
Azure Active Directory
An Azure enterprise identity service that provides single sign-on and multi-factor authentication.
12,562 questions
No comments
{count} votes

1 answer

Sort by: Most helpful
  1. answered 2021-11-11T22:37:57.81+00:00
    Marilee Turscak-MSFT 20,406 Reputation points Microsoft Employee

    Hi @Zurab Sajaia .

    As you have mentioned, it does sound like the other account is being stored somewhere. Azure AD services use cookies to automatically sign in, and I've definitely faced the issue you described before. I would recommend doing the deep logoff with both of these links, in addition to the one you already shared:

    https://login.microsoftonline.com/logout.srf

    https://login.live.com/logout.srf

    You can also sign out of all devices via the Microsoft 365 admin center, or ask your admin to do this for you. https://help.protectedtrust.com/sign-a-user-out-of-all-office-365-apps-and-sessions

    If there's a fresh browser that you've never used to sign in, you can use that to verify if this is happening due to the credential storage and try signing in with the new browser. Normally clearing the cache should work but there have been times when I've been able to resolve this only by using a totally new browser.

    I would recommend trying the troubleshooting steps in this article, and if you are still having this issue after trying those, I would be happy to raise a support request for you.

    Let me know if this helps.

    Thanks,

    Marilee

    No comments