Cannot use the SKU Basic with File Change Audit for site. fileChangeAuditEnabled is NULL from CLI and JSON View

Andrew 1 Reputation point
2021-11-10T21:39:05.46+00:00

Good Day

I'm trying to change an App Service Plan from P1V2 to S1, and I keep getting: Cannot use the SKU Basic with File Change Audit for site XXXX. When I check DuckDuckGO, I find a post about using the CLI to check out fileChangeAuditEnabled. In our case fileChangeAuditEnabled is NULL, and no matter where I try to grab that value from, it's always being returned as null.

I checked out every site under that App Service Plan, 10 of them, and none of the sites have fileChangeAuditEnabled set as TRUE, so I'm unclear as to what I should do.

I was going to submit a ticket, but that will cost me $30 / month, to effectively fix a problem that's caused by a bug in Azure.

Has anyone encountered this issue, and after checking fileChangeAuditEnabled, noticed it was not set to TRUE?

For reference the article I found was: https://nexxai.dev/cannot-use-the-sku-basic-with-file-change-audit-for-site/

Any suggestions are welcome. (I don't know what tag to assign this post)

Thanks!

Azure App Services
Azure App Services
A feature of Azure App Service used to create and deploy scalable, mission-critical web apps.
4,338 questions
No comments
{count} votes

4 answers

Sort by: Most helpful
  1. Deshmukh, Vijit 356 Reputation points
    2022-04-11T10:34:52.947+00:00

    We do not have enabled the log settings for the app service.
    but still not able to edit the plan

    191859-image.png


  2. ajkuma 13,481 Reputation points Microsoft Employee
    2021-11-11T10:50:31.48+00:00

    @Andrew , Firstly, apologies for any inconvenience with this issue.

    1/2:

    Just to give you some background on why this error occurs. The error occurs because the App Service is configured with Diagnostic settings ‘AppServiceFileAuditLogs’ and ‘AppServiceAntivirusScanAuditLogs’. As noted in the Azure doc sec ‘Supported log types'. These log types are not supported for the Standard tier but only premium and above.

    I understand you have tried multiple approaches, even via CLI and/ JSON view. If you haven’t done this already, kindly try directly from the Azure Portal to toggle the logs off.

    I was able to repro the same. Kindly try these steps:

    From the Azure Portal. De-Select ‘AppServiceFileAuditLogs’ and save the settings.
    Next, check to see if you can scale-down the plan.

    If ‘Diagnostic settings’ was set long back, you may consider deleting and re-creating the new settings with those logs enabled and toggle it Off.

    148568-image.png

    Repro error:
    148498-image.png

    No comments

  3. ajkuma 13,481 Reputation points Microsoft Employee
    2021-11-11T10:59:02.54+00:00

    2/2:

    Once again apologies for any inconvenience with this issue.
    We have added right tag on this to receive insights from SMEs and community champions.
    The ~29$ was for the support plan - you don't have to file a ticket, we are here to help you on this.

    • De-Select AppServiceFileAuditLogs and save the settings to remove the true from FileChangeAuditEnabled.
    • Currently, if the settings are just deleted this will not change the flag.
    • App service Plan can have multiple Apps hosted under it.

    After the above the settings change, I was able to scale down-down to Standard tier:
    148527-image.png

    Additional info:
    You may also change values via in Azure Resource Explorer (as mentioned in this blog File Change Audit ruslany, one of PG from App service team)

    There was similar bug reported here - Webapp:az cli does not show the same (correct) information - I will relay the feedback internally to our product team.

    If the issue still persists, please let us know I’ll follow-up with you.


  4. Deshmukh, Vijit 356 Reputation points
    2022-04-25T09:34:54.08+00:00

    Hi ALL,

    Above given solution didn't resolved the problem, as there was no log settings in place
    I moved the app service to other App Service Plan and deleted the existing one :)

    THis can be closed, thanks for the support :)

    No comments