Windows Server Task Scheduler Not Listing Tasks Which Still Run

Jimity 21 Reputation points


Have a bit of a unique one I'm hoping can get solved.

I have a Task in Task Scheduler on a Windows Server (member server) which runs as required at specified times throughout the day.
The task is running as SYSTEM with highest privileges as its mission critical.

As a Sys Admin, when I logon and run Task Scheduler I can see the task listed within the Task Scheduler Library. When a delegated user logs on to that same server and runs Task Scheduler they do not see the task listed. It still runs though.

Through testing with a basic, standalone, work grouped windows client machine, I've found the only way to get a task created under one user to then list in Task Scheduler logged on as another user is to give that user "Administrator" rights. This would seem overkill if transferred to a Windows Server member server scenario. Is there another user privilege on a windows server that could allow the same functionality - that is to allow a delegated user to see Scheduled Tasks within the Task Scheduler Library when that task was originally created under another user account and given the abovementioned security options ?

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
8,224 questions
No comments
{count} votes

Accepted answer
  1. MotoX80 23,651 Reputation points

    That's the way it works. The easiest solution is to have the program that the task executes create a log file that any user can query to see when it last executed and what it did.

    As an alternative, I developed a Powershell script to allow any user to run a task that was defined by an admin.

    If you don't want to allow users to run the task, you will have to modify the $newSD variable to only allow read access.

    No comments

3 additional answers

Sort by: Most helpful
  1. Dave Patrick 330.5K Reputation points Microsoft MVP

    Might check the user has at least list permissions on the files in C:\Windows\System32\Tasks

    --please don't forget to upvote and Accept as answer if the reply is helpful--

    No comments

  2. Jimity 21 Reputation points

    Thanks for the quick reply.
    Sadly no such luck. I experimented a little with Authenticated User group as well without success :(

  3. Georg Matviak 161 Reputation points

    Hello Jimity-0642,

    Do Check out the link below which discuss about similar issue. which might be useful to you in resolving the issue.

    Hope this answers all your queries, if not please do repost back.


    --If an Answer is helpful, please click "Accept Answer" and upvote it--

    No comments