SSRS Report 502 error

Eshwar 176 Reputation points
2021-11-13T01:56:38.527+00:00

HI,
I am getting below error when viewing a report, not sure if it is because of size of the data, sometimes the report comes out fine with same data and sometimes not.
148918-image.png

I tried setting the execution timeout and max request length in web.config
httpRuntime executionTimeout="2147472000" maxRequestLength="2147483647" />
Updated report timeout in reporting services setting

Anything else should I do to make it work?

Thanks,
Eshwar

SQL Server Reporting Services
SQL Server Reporting Services
A SQL Server technology that supports the creation, management, and delivery of both traditional, paper-oriented reports and interactive, web-based reports.
2,120 questions
No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Joyzhao-MSFT 15,361 Reputation points Microsoft Employee
    2021-11-15T03:34:02.957+00:00

    Hi @Eshwar ,
    If the error occurs sometimes when the report is the same, and sometimes it works normally, I think the issue of report execution timeout should be considered.

    Report Execution Timeout
    First of all, if your report is large, check your report and make sure that you only extracted the necessary information. Please use the available filters to extract only the information that is useful to you.
    Once you have filtered the report as much as possible and the report still timed out, you can modify the execution timeout setting in Microsoft Reporting Services (or disable the timeout). Open the report manager (Web portal url)-Site Setting-General. You could then set the number of seconds to 3600. If that does not allow the report to finish, you could then select the "do not timeout" option.
    149207-04.jpg

    HTTP Timeout
    You could set the httpruntime to run the large report,
    You can alter the value of attribute executionTimeout of tag httpRuntime, default value if 9000 and value is in the seconds.

    <system.web>
    <httpRuntime executionTimeout = "9000" />
    </system.web>
    Open the Web.config file. If it does not exist, you must create it in that section.

    If the above setting does not resolve the issue, please feel free to let me know.
    Best Regard,
    Joy


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.