Re-apply "All Application Packages" and "All Restricted Application Packages" permissions to Windows folder

asked 2021-11-17T21:57:36.507+00:00
LongLastingFlavor 216 Reputation points

Hello, I need to re-apply the group\user permissions for "All Application Packages" and "All Restricted Application Packages" to all workstations and was hoping to do this via Group Policy (Computer Configuration\Policies\Windows Settings\File System). This would need to be done to C:\Windows. It seems that I can add "All Application Packages" by changing the location from Domain to the local machine (Domain Controller in this case where we are editing the GPO). But it does not appear you can do this for "All Restricted Application Packages" as it does not appear as an option. Just curious if this is something that can be done via Group Policy or if someone had any suggestions or recommendations on how to accomplish this.

Thank you!

Steve

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
8,146 questions
Windows Group Policy
Windows Group Policy
A feature of Windows that enables policy-based administration using Active Directory.
1,869 questions
Windows Server Security
Windows Server Security
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.Security: The precautions taken to guard against crime, attack, sabotage, espionage, or another threat.
1,296 questions
No comments
{count} votes

2 answers

Sort by: Most helpful
  1. answered 2021-11-17T21:58:40.007+00:00
    LongLastingFlavor 216 Reputation points

    Just a few print screens of what I am needing to accomplish...

    150347-all-app-pack.jpg

    150348-all-restriced-app-pack.jpg

    No comments

  2. answered 2021-12-16T17:32:37.76+00:00
    Limitless Technology 37,291 Reputation points

    In the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout
    Create a new DWORD value IgnoreRemoteKeyboardLayout and give it the value 1.

    That should be sufficient to solve your problem.


    --If the reply is helpful, please Upvote and Accept as answer--

    No comments