SCCM Client (Software Center) Keeps Uninstalling

Henrik Gustavsson 21 Reputation points
2021-11-18T14:30:36.343+00:00

Software Center is installed and working...

150629-working.jpg

... and then some time later, it's gone.

150665-notworking.jpg

I've tried running ccmclean.exe, manually deleted the folders (c:/windows/) CCM, ccmcache, ccmsetup. Run install.bat as admin. When this is done, Software Center is installed again... and then, a while later... gone.

install.bat consists of the following where xxxxxxxx is the company name:

powershell.exe -ExecutionPolicy Bypass -File "\selucmcen01\sccm_client\Clean_Removal_SCCM_Client.ps1"
\selucmcen01\sccm_client\ccmsetup.exe /skipprereq:vcredist_x86.exe;vcredist_x64.exe /source:"\selucmcen01.tp1.ad1.xxxxxxx.com\SCCM_Client" /source:"\tp1.ad1.xxxxxxx.com\smsinstall\ClientSource" /mp:SELUCMCEN01.TP1.AD1.XXXXXXX.COM /BITSPriority:HIGH smssitecode=TP1 smscachesize=20000 SMSMP=SELUCMCEN01.tp1.ad1.xxxxxxx.com ccmhttpport=8008 FSP=selucmdp01 RESETKEYINFORMATION=TRUE CCMLOGMAXHISTORY=5 CCMLOGMAXSIZE=5000000

Microsoft Configuration Manager
No comments
{count} votes

Accepted answer
  1. Rahul Jindal [MVP] 6,251 Reputation points Microsoft MVP
    2021-11-18T16:34:31.123+00:00

    First of all ccmclean is no longer supported. If you have to uninstall ConfigMgr agent, then use ccmsetup.exe with /uninstall switch.

    Secondly, ConfigMgr agent should not uninstall by itself like this. There is obviously an external force in play here. Do you have anything setup in GPO? Did you check in eventvwr for clues?

    No comments

3 additional answers

Sort by: Most helpful
  1. Amandayou-MSFT 10,941 Reputation points
    2021-11-19T08:37:30.353+00:00

    Hi @Henrik Gustavsson

    Agree with RahulJindal, we could check if there is the GPO to prevent installing client, please use gpresult/h to print gpo in the computer.

    Besides, process monitor is an advanced monitoring tool for Windows that shows real-time file system, Registry and process/thread activity. We could use it to monitor computer activity.
    Here is the article about it:
    https://learn.microsoft.com/en-us/sysinternals/downloads/procmon


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments

  2. Henrik Gustavsson 21 Reputation points
    2021-11-25T16:26:57.933+00:00

    Of course our IT department decided that reimaging my laptop would fix the problem (I didn't want this) and it didn't fix anything. So with a "clean" image, I still had the same problem. There was nothing in the event viewer before or after and when I told them that they needed to review GPO all of the sudden, the next day, it worked just fine.

    I'm very frustrated with them because now I've spent the better part of 2-3 days getting everything back to where it needs to be. Thanks for your answers.

    No comments

  3. Tor Arne Nilsen Borgersen 1 Reputation point
    2022-09-23T12:13:15.01+00:00

    Did anyone figure this out?
    Im having the exact same issue with about 200+ computers..

    No comments