SSMS 18.10 (and previous) Grid Columns width is not auto sizing - high resolution screen

Janusz Jasinski 41 Reputation points

Since some versions of SSMS I'm missing auto sizing of columns in Grid view.
Not sure if this is relevant but I'm using SSMS on screen with resolution of 5120x 2880 with 250% scale.
After open to edit 200 top rows it looks like this:


SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
12,267 questions
0 comments No comments
{count} votes

Accepted answer
  1. CathyJi-MSFT 21,111 Reputation points Microsoft Vendor

    Hi @Janusz Jasinski ,

    No, SSMS can’t auto sizing of columns in Grid view.

    Did you try to enable the "Disable display scaling on high DPI" settings which can be done from the SQL Server Management Studio properties section.
    In SQL Server Management Studios Properties -> click on Compatibility tab -> under Settings section-> check the Disable display scaling on high DPI settings.


    We can change the size of the grid results view in SSMS when we find the size of the grid results view is too d small for you.

    In the Tools -> Options window go to the Fonts and Colors tab. Then under Show Settings for: select Grid Results. From there you can change the font to whatever is most comfortable for you. You need to restart the SSMS to make this change effect.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    0 comments No comments

2 additional answers

Sort by: Most helpful
  1. Richard Day 6 Reputation points

    This worked well

    1 person found this answer helpful.

  2. Janusz Jasinski 41 Reputation points

    Thanks it helped, I have to use this150925-screenshot-2021-11-19-112526.png