wsl ubuntu windows terminal

asked 2021-11-20T10:48:51.913+00:00
ninjanoir80 1 Reputation point

I use windows 10 and I just installed the wsl terminal, I used ubuntu distro before. And I use openwrt firmware on my router, I make my own compilation build, usually everything works perfectly but I tried to compile via the wsl terminal from my windows and it is ok but I've always the same error, maybe some of you could help me? thanks

sed -i "s/Installed-Time: .*/Installed-Time: 1637254284/" /home/james/openwrt/build_dir/target-arm_cortex-a9+vfpv3-d16_musl_eabi/root-mvebu/usr/lib/opkg/status
rm -rf /home/james/openwrt/build_dir/target-arm_cortex-a9+vfpv3-d16_musl_eabi/root-mvebu/boot /home/james/openwrt/build_dir/target-arm_cortex-a9+vfpv3-d16_musl_eabi/root-mvebu/tmp/* /home/james/openwrt/build_dir/target-arm_cortex-a9+vfpv3-d16_musl_eabi/root-mvebu/usr/lib/opkg/info/*.postinst* /home/james/openwrt/build_dir/target-arm_cortex-a9+vfpv3-d16_musl_eabi/root-mvebu/usr/lib/opkg/lists/* /home/james/openwrt/build_dir/target-arm_cortex-a9+vfpv3-d16_musl_eabi/root-mvebu/var/lock/*.lock
**find /home/james/openwrt/build_dir/target-arm_cortex-a9+vfpv3-d16_musl_eabi/root-mvebu/ -mindepth 1 -execdir touch -hcd "@1637254284" "{}" +
find: The relative path 'Files/WindowsApps/CanonicalGroupLimited.UbuntuonWindows_2004.2021.825.0_x64__79rhkp1fndgsc' is included in the PATH environment variable, which is insecure in combination with the -execdir action of find.  Please remove that entry from $PATH
make[2]: *** [package/Makefile:73: package/install] Error 1**
make[2]: Leaving directory '/home/james/openwrt'
make[1]: *** [package/Makefile:111: /home/james/openwrt/staging_dir/target-arm_cortex-a9+vfpv3-d16_musl_eabi/stamp/.package_install] Error 2
make[1]: Leaving directory '/home/james/openwrt'
make: *** [/home/james/openwrt/include/toplevel.mk:230: world] Error 2
[1]+  Done                    make download
Not Monitored
Not Monitored
Tag not monitored by Microsoft.
23,703 questions
{count} votes

1 answer

Sort by: Most helpful
  1. answered 2021-11-23T09:09:12.353+00:00
    Limitless Technology 37,291 Reputation points

    Hello Ninjanoir80,

    since OpenWRT is not a Microsoft software, it would be recommend to post your question in a OpenWRT forum, since their community would be better prepared in the execution of compiling and different situations with different OS.


    --If the reply is helpful, please Upvote and Accept as answer--

    No comments