Windows could not apply the registry-based policy settings

Tabir Ali 11 Reputation points
2021-11-21T08:01:16.157+00:00

i have 2 Domain controller 2016 after I restore DC1 from backup and it's running ok but when i run Gpupdate/force on client /Servers workstation i got below error
** Windows could not apply the registry-based policy settings for the Group Policy object LDAP://CN=Machine,CN=xxxxxxxx **

151243-processing-of-gpo-error.png

Windows
Windows
A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
4,946 questions
Windows Server Infrastructure
Windows Server Infrastructure
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.Infrastructure: A Microsoft solution area focused on providing organizations with a cloud solution that supports their real-world needs and meets evolving regulatory requirements.
525 questions
0 comments No comments
{count} vote

1 answer

Sort by: Most helpful
  1. Limitless Technology 39,466 Reputation points
    2021-11-23T09:42:34.527+00:00

    Hello

    Thank you for your question and reaching out.

    1. Ensure the registry.pol file exists in the location and has the same permissions as the gpt.ini file in the same Group Policy object (GPO).
    2. Ensure Sysvol replication is working properly on domain controllers.
    3. Delete the GPO and recreate it.
    4. repadmin /showrepl * /csv >showrepl.csv

    If above steps does not work then follow below steps.
    check the last modified date of the following file:

    C:\Windows\System32\GroupPolicy\Machine\ Registry.pol
    (note: GroupPolicy is a hidden folder, you may need to enable hidden folders to navigate to this path)

    Almost for certain, the last modified date will be a long time ago (or at least earlier than “today”). If this is the case, delete the file REGISTRY.POL, and run “gpupdate /force” from a Command Prompt. This forces the group policies to re-apply. Problem solved :

    https://learn.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/cc727302(v=ws.10)?redirectedfrom=MSDN

    -------------------------------------------------------------------------------------------------------------------------------------------------------------------

    --If the reply is helpful, please Upvote and Accept as answer--

    10 people found this answer helpful.