Windows server firewall drops traffic on "wrong" network profile

Takami Chiro 231 Reputation points
2021-11-23T16:23:42.753+00:00

Hi everyone,

Hope you can help. I am experiencing a strange issue with a windows 2016 firewall.

The server has two nic card, one is to the corporate network and set as "domain" profile. Another one is connect to a network without "internet" and set as "Public" profile. We set the firewall have different policies for the domain and public and private (not used). For example, the policy for public profile does not allow rdp while Domain does.

Everything runs fine until a power outage last Thursday. After the server came up, I need to disable the nics and re-enable so the network profile (domain and public) automatically re-assign to each correct nic.

The problem now is... with the policy to the "Public" profile nic turned on, we cannot rdp or ping to the corporate nic with "Domain" profile policy assigned. We need to turn the policy for "Public" profile off in order to make it to work.

We double checked the policies for the network profiles but they are all correct.

May I ask what to check? Did i miss something somewhere? It is a strrange behaviour.

Thank you very much for your help in advance. Happy Thanksgiving.

Takami Chiro

Windows Server 2016
Windows Server 2016
A Microsoft server operating system that supports enterprise-level management updated to data storage.
2,309 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 39,156 Reputation points
    2021-12-15T16:56:53.06+00:00

    Problems like this occur due to a badly executed configuration, I recommend that you consult the article below with a problem similar to yours, I believe it can help:

    https://social.technet.microsoft.com/Forums/azure/en-US/56ba66d6-bb72-4bff-bbf2-cc480e4127db/network-location-is-incorrect-no-option-to-change?forum=windowsserver2008r2networking


    ---If the answer is helpful, please vote positively and accept the answer--

    0 comments No comments