SharePoint 2019 People Picker Field Not Resolving Users Form Othe Domains

MYA 141 Reputation points
2021-11-23T19:17:45.117+00:00

hello everyone, I have a problem with the SP19 people picker field it shows "multiple entries matched, please click to resolve" the form can be saved normally and the people picker field is showing only 1 name. is this behavior related to trusted domains? and I have to run stsadm..? if yes and I already tried this from cmd I am facing login failure with the error "Unknown SQL Exception 18452 occurred". any suggestions?

Active Directory
Active Directory
A set of directory-based technologies included in Windows Server.
3,656 questions
SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,365 questions
{count} votes

2 answers

Sort by: Most helpful
  1. JoyZ 17,901 Reputation points
    2021-11-25T01:39:33.8+00:00

    @MYA ,

    Please check if your different accounts have the same email address, if so, please delete one of the email addresses to compare the results.

    In addition, here is a similar issue for your reference, the same as you, it only occurs in modern experience:

    https://github.com/Yvand/LDAPCP/issues/94

    Lastly, I will suggest you to open a support ticket about it. It needs more detailed investigation with support team instead of simple troubleshooting via replies in forum. And we will appreciate it if you can update your findings here.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



  2. MYA 141 Reputation points
    2021-11-29T12:05:18.373+00:00

    @JulieWang-MSFT weird behavior from SharePoint modern experience people picker field, the field shows some external users which are not in the same trusted authentication provider.
    for instance, I have a web application with a windows authentication provider and it shows external users but if I switch to classic experience the field work properly. Any idea?

    No comments