Cannot Delete Files in Microsoft SharePoint

Buehler, Stephen 1 Reputation point
2021-11-24T16:21:06.823+00:00

My SharePoint page is full and I'm trying to delete files and I keep getting a couple of error messages

  1. "The site has exceeded its maximum file storage limit. To free up space, delete files you don't need and empty the recycle bin". I am trying to delete files I don't need and both of my recycle bins are empty.
  2. When I select multiple items to delete it says "(insert quantity) items weren't deleted"
  3. When I try and delete full folders it says "You have to delete all the items in this folder before you can delete the folder"

The only thing I've been able to delete are empty folders but even after I empty both of my recycling bins I still have the same error message.

I am not an administrator and am using DoD365

SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
6,015 questions
No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Emily Du-MSFT 24,311 Reputation points Microsoft Employee
    2021-11-25T08:44:53.803+00:00

    @Buehler, Stephen

    The files need to be removed permanently from this site (second stage recycle bin as well) in order to free storage space. Whether you delete files in the end user recycle bin and site collection recycle bin?

    Please follow below tips to troubleshooting the issue.

    1.Make sure that files are checked in.
    2.Make sure that you have the appropriate permission to delete files.
    3.Check whether the site collection has retention policy is enabled.
    4.Try to increase the site collection quota, then delete files.
    5.Try to use PowerShell to delete files.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.