How do I disable this feature?

Asher Brammer 1 Reputation point
2021-11-25T01:53:45.137+00:00

It's something called "IIS"
I want to use a localhost website but it doesn't work it just shows this152310-problem.png

It won't let me go and if I click it it brings me to www.iis.net

And I just want to use it normally

Internet Information Services
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Bruce Zhang-MSFT 3,736 Reputation points
    2021-11-25T05:58:33.677+00:00

    Hi @Asher Brammer ,

    The page you see is the default page of IIS. Usually we use it as a test page to check if IIS installed successfully. You can find this page in C:\inetpub\wwwroot and name is iisstart.htm.
    152377-1.jpg

    IIS has a Default Web Site when install successfully by default. Its corresponding physical path is C:\inetpub\wwwroot. You can explore it through right click the default web site.
    152370-2.jpg

    I'm not sure which feature you want to disable. But IIS has a module called Default Document. It helps sites to show home page without add page name after root url. It is enable by default. That is why iisstart.htm shows when the url is http://localhost:80.
    152464-3.jpg

    You can disable this module and enter page name to use it normally. For example, I create a custom page called example.html and put it in C:\inetpub\wwwroot.
    152502-4.jpg
    Then I can access it through http://localhost/example.html.
    152429-5.jpg


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    Best regards,
    Bruce Zhang

    0 comments No comments