SSIS package doesn't run from CMD 0xC000F427

asked 2021-11-26T08:17:09.043+00:00
Peter Ustinov 1 Reputation point

I have a rather simple SSIS package that is supposed to read data from DB1, save that data to a CSV file and then also write that same data to DB1 - when I'm running said package from within Visual Studio it's working perfectly fine, CSV being created and DB2 being written to.

When I try to run the package via CMD however, I can't get it to work - that is, I can get it to work, but the moment I activate the "write to CSV" parts, it doesn't work anymore. Which is odd, since we have plenty of packages that already do pretty much the same job, it's just that this one is for some reason not working.

I'm correctly running the 32bit version and I've correctly aligned the target SQL server version. Again, the package is running perfectly fine when it's just "read from DB1 and write to DB2" - whenever I activate the CSV part it's giving me error 0xC000F427 (executing a package outside of SSDT requires IS standard edition yada yada) - it can't be missing software though since I already have other packages doing virtually the same.

Anyone any ideas on what's causing this behavior?

SQL Server Integration Services
SQL Server Integration Services
A Microsoft platform for building enterprise-level data integration and data transformations solutions.
1,839 questions
No comments
{count} votes

4 answers

Sort by: Most helpful
  1. answered 2021-11-26T08:31:47.727+00:00
    Olaf Helper 25,476 Reputation points

    Are you running the package on the server where SSIS is installed?
    Error 0xC000F427 often means, there is no running /ibstalled SSIS server.

    No comments

  2. answered 2021-11-26T09:20:10.45+00:00
    Peter Ustinov 1 Reputation point

    Yes, SSIS 14.0 is installed on that server, but regardless of target server version the package is still not running outside of Visual Studio.

    No comments

  3. answered 2021-11-29T01:37:54.3+00:00
    ZoeHui-MSFT 18,671 Reputation points Microsoft Employee

    Hi @Peter Ustinov ,

    From the error message, it seems that the SSIS is not installed in your machine.

    As you said that you are using SSIS14.0, it should be SQL Sever2017.

    When you run the dtexec in cmd, have you tried to use C:\Program Files (x86)\Microsoft SQL Server\140\DTS\Binn\dtexec.exe to specify the version?

    Is there several different SSIS versions in your machine? You may have a double check.

    Regards,

    Zoe


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments

  4. answered 2021-11-29T06:43:29.297+00:00
    Peter Ustinov 1 Reputation point

    Hi, I've tried all Target Server Versions from 2012 to 2017, with all DTexec from 90 up to 130 (don't have the 140 one installed) - none of them work.
    There's several old packages running with 2012 Server and 90 DTexec and some more recent ones with 2017 and 110/130, no matter how I configure this one, it's telling me that SSIS weren't installed.

    No comments