Vs2022 download error, unable to install microsoft.netcore.hostpath

梓睿 李 6 Reputation points
2021-11-28T14:29:05.607+00:00

I tried to download vs2022 in Windows10 21H1, and imported the configuration of vs2019 into vs2022, but when vs2022 was downloaded, Vs install tip can't install the Core Microsoft.Net. HostPath computer restart again also does not have any effect, I think it will lead to the mistake I can't open. Net Core project, and the fact is that, I hope the developers can tell me the solution as soon as possible, thanks!

VB
VB
An object-oriented programming language developed by Microsoft that is implemented on the .NET Framework. Previously known as Visual Basic .NET.
2,502 questions
Visual Studio Setup
Visual Studio Setup
Visual Studio: A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.Setup: The procedures involved in preparing a software program or application to operate within a computer or mobile device.
937 questions
{count} votes

3 answers

Sort by: Most helpful
  1. 梓睿 李 6 Reputation points
    2021-11-29T11:49:35.32+00:00

    Hi,@Anna Xiu-MSFT

    For some network reasons, I couldn't open Onedrive, so I chose Github instead

    Unable to install the Core Microsoft.Net. The HostPath problem seems to have been resolved, I use vs installer fixes the repair function, but now it appeared the following two questions:

    153259-qq%E6%88%AA%E5%9B%BE20211128212812.jpg

    The vslogs.zip file I uploaded to Github was created after I fixed it three times

    1 person found this answer helpful.
    0 comments No comments

  2. Anna Xiu-MSFT 23,251 Reputation points Microsoft Vendor
    2021-11-30T08:31:28.807+00:00

    Hi @梓睿 李 ,

    Please try to delete the following corrupted packages and repair your installation.
    F:\ProgramData\Microsoft\VisualStudio\Packages\Microsoft.VisualStudio.EntityFrameworkTools.Msi,version=17.0.31912.81
    F:\ProgramData\Microsoft\VisualStudio\Packages\Microsoft.Net.CoreSDK.50,version=1.0.23909

    Sincerely,
    Anna
    *
    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  3. Mihrteab Bahiru 1 Reputation point
    2022-03-09T17:58:57.11+00:00

    Hi there, I ran into the same problem and I tried searching for solution on the internet, and surprisingly I couldn't find one even on the official Microsoft website. Unfortunately the issue was simple, maybe that's why the team didn't address it quickly. The solution is simple, if you have and type of security software's like smadav, windows defender or any type of antivirus on, try disabling it and re-install or repair VS, or if there is a setting enabled like "auto-blocking" or similar setting like that in your antivirus, disable that and try re-installing or repairing VS. I hope this helps, thanks.

    0 comments No comments