Sharepoint 2019 - anonymous access site still prompts for credential

Daniel M 121 Reputation points
2021-11-29T11:59:50.447+00:00

Hi,

I am trying to set a sharepoint 2019 claims-based web app as being available to anonymous users since this web front should be reachable from the internet.
The problem is that the web browser still prompts me for credentials.
I have followed this guide to set it up:
https://www.enjoysharepoint.com/enable-anonymous-access-sharepoint-2013/

And I have followed these guides to troubleshoot:
https://www.koskila.net/troubleshooting-anonymous-access-sharepoint-onpremises/
https://www.sharepointdiary.com/2015/05/fix-login-prompt-on-anonymous-access-enabled-sharepoint-sites.html

It seems that I have done everything as one should.
The problem is that I get a credential prompt, and when I click "cancel" I still get to see everything on the site.
If I use fiddler and click "cancel" I can see that I get a HTTP 401 from a custom style sheet in the Style Library. But that library has anonymous access enabled on it. The entire style library inherits permissions from the site which also has anonymous access enabled on the entire site.

By the way, the site collection feature "Limited-access user permission lockdown mode" is not activated.

Any thoughts on what the next step for troubleshooting might be?

SharePoint Server
SharePoint Server
A family of Microsoft on-premises document management and storage systems.
1,457 questions
No comments
{count} votes

Accepted answer
  1. sadomovalex 3,591 Reputation points
    2021-11-29T16:40:57.493+00:00

    are all files in Pages and Style library published with major version? Also check is master page (Catalogs > Master pages) published with major version.


1 additional answer

Sort by: Most helpful
  1. Emily Du-MSFT 24,471 Reputation points Microsoft Employee
    2021-11-30T02:57:15.243+00:00

    @Daniel M

    I can reproduce the issue in my SharePoint.

    To resolve this issue, when you set Anonymous Access, uncheck the box for “Require Use Remote Interfaces permissions”.

    153524-1.png


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.