Problem deploy project to SSIDB catalog

Faina Furman 1 Reputation point
2021-11-29T21:24:05.62+00:00

I can't deploy project to SSISDB catalog.
See below my error:
.NET Framework error occurred during execution of user-defined routine or aggregate "deploy_project_internal":

System.ComponentModel.Win32Exception: A required privilege is not held by the client

System.ComponentModel.Win32Exception:

at Microsoft.SqlServer.IntegrationServices.Server.ISServerProcess.StartProcess(Boolean bSuspendThread)

at Microsoft.SqlServer.IntegrationServices.Server.ServerApi.DeployProjectInternal(SqlInt64 deployId, SqlInt64 versionId, SqlInt64 projectId, SqlString projectName)

. (.Net SqlClient Data Provider)

SQL Server Integration Services
SQL Server Integration Services
A Microsoft platform for building enterprise-level data integration and data transformations solutions.
2,408 questions
0 comments No comments
{count} votes

6 answers

Sort by: Most helpful
  1. ZoeHui-MSFT 30,411 Reputation points
    2021-11-30T02:07:24.81+00:00

    Hi @Faina Furman ,

    If you change the SSIS service account from the default, you may have to give additional permissions to the non-default service account before you can deploy packages successfully. If the non-default service account doesn't have the required permissions, you may see the following error message.

    A .NET Framework error occurred during execution of user-defined routine or aggregate "deploy_project_internal": System.ComponentModel.Win32Exception: A required privilege is not held by the client.

    This error is typically the result of missing DCOM permissions. To fix the error, do the following:

    1.Open the Component Services console (or run Dcomcnfg.exe).
    In the Component Services console, expand Component Services > Computers > My Computer > DCOM Config.
    2.In the list, locate Microsoft SQL Server Integration Services xx.0 for the version of SQL Server that you're using. For example, SQL Server 2016 is version 13.
    3.Right-click and select Properties.
    4.In the Microsoft SQL Server Integration Services 13.0 Properties dialog box, select the Security tab.
    5.For each of the three sets of permissions - Launch and Activation, Access, and Configuration - select Customize, then select Edit to open the Permission dialog box.
    6.In the Permission dialog box, add the non-default service account and grant Allow permissions as required. Typically, an account has Local Launch and Local Activation permissions.
    7.Click OK twice, then close the Component Services console.
    For more info about the error described in this section and about the permissions required by the SSIS service account, see the following blog post:
    system-componentmodel-win32exception-a-required-privilege-is-not-held-by-the-client-while-deploying-ssis-project

    deploy-integration-services-ssis-projects-and-packages

    Regards,

    Zoe


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Yitzhak Khabinsky 24,561 Reputation points
    2021-11-30T13:33:56.937+00:00

    Hi @Faina Furman ,

    It is not clear how you are trying to deploy SSIS Project:

    • From Visual Studion on a dev. workstation.
    • From SSMS by using *.ispac file.

    In any case, please try to add your Active Directory (AD) account to the ssis_admin role in the SSISDB database on the SSIS run-time server.

    153766-ssis-ssis-admin-role-2021-11-30-101322.png


  3. Faina Furman 1 Reputation point
    2021-11-30T18:11:37.457+00:00

    I added AD account in ssidb-->security->users and after them add this user
    in Roles --database Roles --ssis_admin-->Role Members.

    Nothing changed...


  4. Faina Furman 1 Reputation point
    2021-11-30T20:12:44.263+00:00

    Sorry I deleted image


  5. Faina Furman 1 Reputation point
    2021-11-30T20:24:11.693+00:00

    yes. this account.
    how can I delete this image?