Windows security popup not shows in secure desktop

Jyothi R 6 Reputation points
2021-12-01T12:54:43.767+00:00

I have created one webview2 based application to support multifactor-authentication(MFA). I am trying to implement this in secure desktop(new desktop).

When I tried to trigger MFA sign in, after launching the application in secure desktop, windows security popup did not appear there. Instead the popup appeared in the previous desktop.

I want to make this popup appear in secure desktop.

Is there any solution to bring the windows security dialog in secure desktop. Can you suggest a solution for this ?

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
2,041 questions
Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,219 questions
C++
C++
A high-level, general-purpose programming language, created as an extension of the C programming language, that has object-oriented, generic, and functional features in addition to facilities for low-level memory manipulation.
3,446 questions
Windows 10 Security
Windows 10 Security
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Security: The precautions taken to guard against crime, attack, sabotage, espionage, or another threat.
2,698 questions
{count} vote

1 answer

Sort by: Most helpful
  1. Limitless Technology 39,196 Reputation points
    2021-12-02T09:52:28.227+00:00

    Hi there,

    In the secure desktop try resetting the network and check if you can re-enable the Security pop-up.

    -Press Windows key + I to open the Settings app.
    -Open Network & Internet.
    -Select Status from the left pane
    -Scroll to the bottom and click on Network Reset.
    -Restart the PC and check if the pop-up is enabled.


    --If the reply is helpful, please Upvote and Accept it as an answer--

    0 comments No comments