Remote Desktop App stuck on "Configuring remote session" but works well on PC

Johnn G 11 Reputation points
2021-12-02T13:12:39.833+00:00

As I said, the app doesn't work on my phone however it works well on any PC I use. The app was working and I was able to connect a few times but now I cant. I get stuck at "Configuring remote session". I have deleted the PC from the app several times as well as uninstalling and reinstalling the app several times without any luck. I can still access it through a PC however my phone no longer connects for some reason.

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,152 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Bomale.io 1 Reputation point
    2022-03-20T02:14:15.743+00:00

    I have solved removing data of "Microsoft remote desktop" app on Android app settings and recreate the PC connection data

    0 comments No comments

  2. George Bradley 0 Reputation points
    2023-10-21T03:43:07.1966667+00:00

    It appears to be a problem with the app. If you are trying to connect to an older PC, before it connects it has a screen that says "Identity of remote PC can't be verified." If you check the box "Never ask again for connections to this PC" and then connect, you will never be able to connect again (for my remote XP computer but not my remote Windows 10 computer). Apparently, it prevents asking and answering the question when it should automatically answer "Connect." The only solution I found on my Android was to delete all the App data (App Info, Storage, Clear Data). You lose all your connection data (PC's, Gateways, and User Accounts) so you're starting all over.

    0 comments No comments

  3. Alireza Poorasad 0 Reputation points
    2024-02-05T16:59:34.7533333+00:00

    I can fix it on Samsung G54, by Enable Disable Always Prompt for Password in Group Policy Editor on windows 10

    Open Group Policy Editor and navigate to Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Security.

    In the right window, double-click on Always prompt for password upon connection.

    Not configured - Default
    Enabled - Enable prompt for a password
    Disabled - Same as not configured