How to set gMSA account in physical path credentials property

michal kavi rajan 6 Reputation points
2021-12-04T03:09:07.003+00:00

Trying to setup classic ASP application in IIS 10. Anonymous Authentication is disabled. Windows Authentication is enabled. This application is currently running using normal service account. Wanted to change it to gMSA account for better password mangement.

As the application is using windows based authentication, the service account is configured for IIS app pool and physical path property for the SQL connection from application to work.

I am able to configure gMSA account for app pool without password. However while setting the gMSA account in physical path property getting error as password is invalid , invalid user id.

Is it possible to use gMSA account for IIS physical path property?
If Yes, how to set it up?

Internet Information Services
0 comments No comments
{count} vote

1 answer

Sort by: Most helpful
  1. Bruce (SqlWork.com) 52,491 Reputation points
    2021-12-04T18:08:13.577+00:00