'Retired' Text Analytics version error

2JK 241 Reputation points
2021-12-05T14:12:58.127+00:00

I am running code using Databricks that basically performs a few text analysis on text. All was working until December 1 when I started getting this strange error. There was nothing on it, no documentation, nothing. I just simply install the text analytics library at the beginning, authenticate then call the methods on it. Any method that is called on the client throws this error.

Encountered exception. (Gone) Text Analytics/3.1-preview.3 has been retired. Please upgrade to v3.1. See the following page for added details: https://aka.ms/ta-get-started-sdk
Code: Gone
Message: Text Analytics/3.1-preview.3 has been retired. Please upgrade to v3.1. See the following page for added details: https://aka.ms/ta-get-started-sdk

I can't share much of the code but I didn't touch the code so it's 100% not an issue from there. Not sure how the error can even be replicated. I'm using python 3.5.7 (as per the Databricks: sys.version). Running the same code anywhere else like Colab or locally doesn't throw this error.

Azure Databricks
Azure Databricks
An Apache Spark-based analytics platform optimized for Azure.
1,845 questions
Azure AI Language
Azure AI Language
An Azure service that provides natural language capabilities including sentiment analysis, entity extraction, and automated question answering.
328 questions
Azure AI services
Azure AI services
A group of Azure services, SDKs, and APIs designed to make apps more intelligent, engaging, and discoverable.
2,195 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. GiftA-MSFT 11,141 Reputation points
    2021-12-07T01:35:12.397+00:00

    Hi, can you try to reinstall the client library and if needed upgrade python version to 3.6 or later?

    0 comments No comments

  2. 2JK 241 Reputation points
    2021-12-07T14:47:11.697+00:00

    Hi. This was resolved when I created a new cluster and reinstalled everything.

    I tried reinstalling the client library before but it didn't work. Not really sure what the problem could have been.

    0 comments No comments