How to fix "The project doesn't know how to run the profile ConsoleREPL" in Visual Studio?

Steve S 11 Reputation points
2021-12-07T22:50:50.617+00:00

I'm trying out PowerFx using the instructions on this page: https://powerapps.microsoft.com/en-us/blog/power-fx-open-source-now-available/

I installed the community version of Visual Studio 2022 on Windows 10. I cloned the repository for PowerFX Host Samples and built the ConsoleREPL solution. Worked fine. When I select "Start Debugging" I get a popup that says "The project doesn't know how to run the profile ConsoleREPL".

Please advise how to fix. I'm an experienced developer on other platforms, but not on Windows and have never used Visual Studio.

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
4,441 questions
C#
C#
An object-oriented and type-safe programming language that has its roots in the C family of languages and includes support for component-oriented programming.
9,983 questions
{count} votes

5 answers

Sort by: Most helpful
  1. Adam Mikolajczyk 26 Reputation points
    2022-04-08T15:44:26.667+00:00

    The "project doesn't know how to run the profile..." error appears to be related to the Development Tools for .NET option in the .Net desktop development installation of Visual Studio 2022. It should be possible to resolve the problem by modifying the VS install to add this component. I'm not sure what else this component is affecting so it seems like MS might need to promote it from "optional" to "included".

    191419-vs-community-2022.jpg

    5 people found this answer helpful.

  2. Tianyu Sun-MSFT 25,571 Reputation points Microsoft Vendor
    2021-12-08T01:38:42.39+00:00

    Hi @Steve S ,

    Welcome to Microsoft Q&A forum.

    Sounds like a potential issue, if you try to repair Visual Studio, will Visual Studio 2022 work?(Visual Studio Installer > find Visual Studio 2022 > click More > click Repair > wait for VS complete repairing)

    Feel free to let me know the result.

    Best Regards,
    Tianyu

    • If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
      Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

  3. LT 1 Reputation point
    2021-12-23T02:01:09.94+00:00

    I changed my account to administrator and created a new app. Now it opens the console.


  4. Yassin Ahmed 1 Reputation point
    2022-09-11T19:04:28.003+00:00

    Hello steve seems Like you have a problem With building/Running test, To fix that you need to update VS To latest Version and repair Visual Studio from Visual Studio installer in available tab
    Message me if it worked

    ---Yaslongi


  5. Alan Churchill 1 Reputation point
    2022-10-09T22:53:22.113+00:00

    I had the same error message but the unknown component was MSIX in WinUI 3. Well, MSIX is VS development so I added that component. That didn't do it completely. I had installed Windows App SDK previously. I went into the VS Installer and it wasn't checked under individual components so I checked that. Then I had to change Configuration Manager so Deploy was checked. Then it worked. Hope it helps someone.

    The tooling on WinUI is a bit raw right now. Hopefully, it gets fixed soon. Love it other than that.

    0 comments No comments