Localisation of Azure AD B2C custom policy showing unicode characters instead actual letter

AB 156 Reputation points
2020-01-15T20:08:46.94+00:00

I'm trying to implement localisation in custom policies and created localised resources:

alt text

When it is renders in browser, for

"Correo electrónico o número de teléfono"

it is showing as Correo electrónico o número de teléfono

The data uri i'm using is urn:com:microsoft:aad:b2c:elements:contract:selfasserted:2.0.0 and using my own html page. I can add one more thing, the unicode charecters are showing only for labels, placeholder of the text box is perfect.
I tried the prior version of DATAURI

urn:com:microsoft:aad:b2c:elements:contract:selfasserted:1.2.0

This worked, so i think this is the issue of version 2.0.0.

Microsoft Entra External ID
Microsoft Entra External ID
A modern identity solution for securing access to customer, citizen and partner-facing apps and services. It is the converged platform of Azure AD External Identities B2B and B2C. Replaces Azure Active Directory External Identities.
2,770 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. AmanpreetSingh-MSFT 56,506 Reputation points
    2020-01-16T10:26:11.353+00:00

    @AB Yes, you are right. I also encountered same behavior in my environment after updating to version 2.0.0. I will report this issue to the product group for a fix.

    0 comments No comments

  2. SvenGlöckner 441 Reputation points
    2021-04-16T13:19:04.753+00:00

    Any news here? This bug still persists. I'm already using page version 2.1.0 - bug still there.

    0 comments No comments