Share via

Azure Site Recovery - Replication Health Critical

Cloud_Geek_82 886 Reputation points
Dec 9, 2021, 12:16 PM

Hi guys,

I set up Azure Site Recovery and replicating 7 servers.
1 domain controller
3 SQL servers and 3 web servers.
Out of 7 servers 2 have Replication Health - Critical.

156294-asr-repl-01.jpg

Below are the errors.

*TSTSQLVAN01
Error ID
78206
Error Message
VSS writer failed for an application. App consistency recovery points cannot be generated.

Possible causes
VSS writer SqlServerWriter failed with error 0x800423f4 during After DoSnapshotSet phase on the source machine.

Recommendation
1. For common issues, refer https://aka.ms/vss-writer-failures.
2. Please contact application vendor(s) for issue resolution.

Related links
https://aka.ms/vss-writer-failures
First Seen At
12/9/2021, 10:59:29 PM
Error ID
78144
Error Message
No application consistent recovery point available for the VM in the last 240 minutes.
Possible causes
1. Replication is delayed due to network connectivity issues or low bandwidth availability.
2. If the source machine is Windows, Azure Site Recovery VSS provider is missing or a VSS writer is causing application consistent snapshot failures. Upgrade to 9.28 or above to get VSS related errors.
3. The data change rate (write bytes/sec) for one or more disks of the source machine has exceeded ASR supported limits. Refer https://aka.ms/asr-v2a-target-limits.

Recommendation
1. Ensure that the target storage type (Standard or Premium) is provisioned as per the churn rate requirement at source.
2. For troubleshooting refer https://aka.ms/v2a_app-consistency-failure
3. If you do not need application consistency for this source machine, update the replication policy to have app consistency frequency of zero.
4. If the issue persists contact support.

Related links
https://aka.ms/v2a_app-consistency-failure
First Seen At
12/2/2021, 10:22:02 AM*

*PRODWEB01
Error ID
78144
Error Message
No application consistent recovery point available for the VM in the last 240 minutes.
Possible causes
1. Replication is delayed due to network connectivity issues or low bandwidth availability.
2. If the source machine is Windows, Azure Site Recovery VSS provider is missing or a VSS writer is causing application consistent snapshot failures. Upgrade to 9.28 or above to get VSS related errors.
3. The data change rate (write bytes/sec) for one or more disks of the source machine has exceeded ASR supported limits. Refer https://aka.ms/asr-v2a-target-limits.

Recommendation  
      1. Ensure that the target storage type (Standard or Premium) is provisioned as per the churn rate requirement at source.  
      2. For troubleshooting refer https://aka.ms/v2a_app-consistency-failure  
      3. If you do not need application consistency for this source machine, update the replication policy to have app consistency frequency of zero.  
      4. If the issue persists contact support.  
      
Related links  
    https://aka.ms/v2a_app-consistency-failure  
First Seen At  
11/20/2021, 10:24:44 AM*  

I tried to reboot both machines but replication health for both machines still Critical.
At the same time I can see recovery points are created regularly.

156254-asr-repl-02.jpg

Could you please advise:

  1. Why is it so even with all VSS writers in Stable status?
  2. In terms of data replication are these servers and data replicated or not?
  3. What is "Latest app-consistent - Not available" and what could be implications in case of failover?

Thanks in advance.

Azure Site Recovery
Azure Site Recovery
An Azure native disaster recovery service. Previously known as Microsoft Azure Hyper-V Recovery Manager.
756 questions
{count} votes

Your answer

Answers can be marked as Accepted Answers by the question author, which helps users to know the answer solved the author's problem.