Moving an Azure App Service to another existing App Service Plan

Phyxsius 16 Reputation points
2021-12-10T19:53:46.887+00:00

I would like to move my Azure App Service to another existing App Service Plan with the use of "Change App Service Plan" option.
As you can see in the screenschots both App Service Plans (***Plan and ***Plan01) are in the same region (West Europe) and Resource group (***portal).
So I am ticking all the necessary requirements.

If so the "Change App Service Plan" menu doesnot show the other App Service Plan.
Any idea what I am missing or away to figure it out.

To make things even more frustrating I have the exact same setup, where it does work and the only difference is that the other App Service Plan has been creating with the use of the option within "Change App Service Plan" menu named "Create new".

156775-z4mvtdoozn.png

156735-microsoftazureportal-vp65kmaltk.png

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
6,484 questions
0 comments No comments
{count} vote

3 answers

Sort by: Most helpful
  1. Jaliya Udagedara 2,716 Reputation points MVP
    2021-12-11T04:11:39.883+00:00

    Technically, You can move an app to another App Service plan, as long as the source plan and the target plan are in the same resource group and geographical region which is true in your case.
    Reference: https://learn.microsoft.com/en-us/azure/app-service/app-service-plan-manage#move-an-app-to-another-app-service-plan

    Unfortunately, we can't change the App Service Plan through CLI, otherwise, it would have shown more information.

    And I just tried the same scenario, created new apps and service plans, for me, it seems to work.
    156797-image.png

    In this case, I am sorry, I would suggest reaching out to @AzureSupport

    2 people found this answer helpful.
    0 comments No comments

  2. Phyxsius 16 Reputation points
    2021-12-23T09:01:14.003+00:00

    in the meantime, found the isseu by checking the diffence between all App Service Plan's by requesting "Resource JSON"
    is seems the cause is "webSpace"

    159870-image.png

    more in this here: https://learn.microsoft.com/en-us/azure/app-service/app-service-plan-manage#:~:text=Azure%20deploys%20each%20new%20App,created%20in%20the%20same%20webspace.

    2 people found this answer helpful.
    0 comments No comments

  3. Jose Parra 11 Reputation points
    2022-09-02T10:29:20.553+00:00

    Hi,
    Another option is to create a new app service in the target App Service Plan, and then restore a backup of the original app service into the new app service, copying the advanced settings.

    It worked for me. I had to do in that way because, in my case, despite the target and source regions where the same, and the resource group was the same for target and source plans, the webspace was different (I think that was because some time ago I changed the resource group and webspace get stacked to an old one).

    2 people found this answer helpful.
    0 comments No comments