Can not put data from file to DB

灿昊 王 21 Reputation points
2021-12-13T21:36:14.853+00:00

157286-%E5%9B%BE%E7%89%87.png

You can see the picture, COMM_TTL size still shows 50 when I modify it to 500. This may cause the fail result when data lengh in this column bigger than 50.

157190-%E5%9B%BE%E7%89%87.png

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
12,323 questions
0 comments No comments
{count} votes

Accepted answer
  1. AmeliaGu-MSFT 13,956 Reputation points Microsoft Vendor
    2021-12-14T05:40:01.01+00:00

    Hi 16625862,
    Welcome to Microsoft Q&A.
    What the data source are you using?
    If you are using Flat File Source, please try to go to Choose a Data Source tab-> select Advanced in the left pane. Then select the column COMM_TTL and set OutputColumnWidth to larger value.
    For example:

    157359-image.png

    Best Regards,
    Amelia


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

3 additional answers

Sort by: Most helpful
  1. 灿昊 王 21 Reputation points
    2021-12-14T23:43:24.683+00:00

    OK, I will try it, thank you for your reply!

    0 comments No comments

  2. 灿昊 王 21 Reputation points
    2021-12-15T00:45:03.393+00:00

    Thanks! It finally works! Besides, it need Administrator Permission to execute.

    0 comments No comments

  3. 灿昊 王 21 Reputation points
    2021-12-15T00:46:44.64+00:00

    However, I think this GUI still has some problems in that Column mapping page. If you only modify type & size in that page, it doesn't work.

    0 comments No comments