Constantly have to reset my wireless adaptater to get wifi

Ersin Karaduman 1 Reputation point
2021-12-14T10:49:59.367+00:00

Hello,

I'm on an Asus tuf gaming a15 laptop with an UEFI bios my wireless adaptater is : Realtek 8822BE Wireless LAN 802.11ac PCI-E NIC

My PC keep losing the wifi all the time and I constantly have to reset the wireless adaptater to get the wifi back ...

I tried a lot of things :

-update Realtek driver ( it seems it doens't work because when I check the driver after the installation it stay the same "2024.0.10.102" )

-uninstall driver and reboot PC

-install previous Driver

-reinstall windows (done 2 times )

-repair windows with installation ISO

-change automatic DNS to static

-Removed the checkmark beside Allow the computer to turn off this device to save power.

-Forget the network

-Reset the TCP/IP settings on your PC and reset the winsock catalogue

-check if the wifi is on private

i have the same problem like this guy: https://social.technet.microsoft.com/Forums/ie/en-US/d75f9902-0146-421b-b794-76ad91bc7dc3/constantly-have-to-reset-my-wireless-adaptater-to-get-wifi?forum=win10itpromobile

Windows 10 Network
Windows 10 Network
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Network: A group of devices that communicate either wirelessly or via a physical connection.
2,247 questions
{count} votes

10 answers

Sort by: Most helpful
  1. Wira Mahavira Wisesa 6 Reputation points
    2022-03-10T00:31:24.253+00:00

    I had the same issue when upgraded to Windows 11.
    But when I tried upgrading the driver to 2024.0.10.226, The Wi-Fi issues are gone and its fixed! Give it a try!

    I got the driver from this site: realtek-8822be-wireless-lan-802-11ac-pci-e-nic
    Direct download link: Realtek-10x64-E_2024.0.10.226-drp.zip

    My laptop is Asus TUF FX505DD btw

    1 person found this answer helpful.

  2. franco d'esaro 271 Reputation points
    2021-12-14T16:37:33.32+00:00

    Hi.
    Please specify the version and build of Windows 10 and the Firewall / Antivirus you are using.
    Are the router and laptop close or far apart? Are the 2 devices on the same floor of the house?
    Go to Device Manager, select your Wi-Fi adapter, click on the Advanced tab, search for Wireless Mode, expand the drop-down menu, post the screenshot with the current setting.
    Try following here too:
    https://support.microsoft.com/en-us/windows/wi-fi-problems-and-your-home-layout-e1ed42e7-a3c5-d1be-2abb-e8fad00ad32a

    0 comments No comments

  3. Ersin Karaduman 1 Reputation point
    2021-12-14T17:15:29.767+00:00

    My router is on the same floor as my laptop, the problem is probably not my router because all my other devices are working fine. 157507-screenshot-224.png157526-screenshot-223.png

    0 comments No comments

  4. franco d'esaro 271 Reputation points
    2021-12-14T17:42:41.513+00:00

    In the text of your question you stated that you have a Realtek 8822BE Wireless LAN 802.11ac PCI-E NIC Wi-Fi adapter instead from the screenshot you sent it turns out to be a different model.
    Why did you set Wireless Mode in IEEE802.11a? Set the Wireless Mode to AUTO.
    You have not specified which is your Firewall / Antivirus in use.

    0 comments No comments

  5. Ersin Karaduman 1 Reputation point
    2021-12-14T18:03:43.017+00:00

    The wireless mode is set on auto, I have the regular Windows Firewall and Antivirus.

    0 comments No comments