Anyone else having trouble resetting the VM password?

Pflipper 96 Reputation points
2021-12-14T18:31:53.967+00:00

Password expired and trying to change through the Azure menu. Does not work. Is it supposed to? Password meets all the requirements.

157583-capture.png

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
6,772 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Praveen Prabhakaran 546 Reputation points Microsoft Employee
    2021-12-15T02:26:22.467+00:00

    @Pflipper

    VM reset password fails for different reasons. one of the main reason is the VM agent, could you please check if the VM agent is up and running for the VM??

    if the agent is running you can also use the run commands to reset the password. (assuming its a windows VM)

    reset password:
    net user adambertram P@ssw0rd1

    Add new user:
    net user <username> <newpassword> /add /Y
    net localgroup administrators <username> /add

    even if this doesn't work and the VM is in a un usable state we may need to follow the offline password reset approach.


  2. KarishmaTiwari-MSFT 17,237 Reputation points Microsoft Employee
    2021-12-16T20:07:34.443+00:00

    Apologies for the inconvenience caused. I reproduced the scenario and observed the following.

    • First time I tried to reset the password, I got the same error message as you - "Update failed." and "Failed to Reset Password" in the Notifications tab.

    158277-image.png

    • I went to the VM resource -> Settings -> Extensions + Applications -> enablevmaccessa -> clicked on it and checked the detailed error message.

    158296-image.png

    • The error message says - "The password does not meet the password policy requirements. Check the minimum password length, password complexity and password history requirements"

    158381-image.png

    • I tried resetting the password again. This time I made sure the password contains 1 uppercase character, 1 lowercase character , 1 number, 1 special character, is between 12 -123 characters long and it is not similar to previous passwords for that VM
    • Checked the Notifications tab and it said "Successfully reset password"

    ![158326-image.png

    • Checked the detailed error message under VM resource -> Settings -> Extensions + Applications -> enablevmaccessa and it has status as Provisioning succeeded.

    158346-image.png

    Based on the above repro and my observations, I think the update failed in your case because of Password policy requirements. Please give the 'Reset Password' functionality on Azure portal another try, following all password requirements as stated above and let me know the results. If you are still seeing this issue, I will further investigate this, get on a call with you or involve the product team as needed.