Using SQL Express I am seeing certain insert commands not executing in real time.

Bob Fischer 71 Reputation points
2021-12-14T22:07:24.197+00:00

They are executed after the main process, which has its own set of select/insert statements, is done and closes its connection. All of the operations work against the same database and tables using the same connection global in VB.NET. No data is lost. The 'cached' commands execute from subroutines of the main process, with their own connection object. Transactions are used but committed and the connection closed after each insert in the subroutine. Does SQL Express not support this simultaneously?

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
12,237 questions
VB
VB
An object-oriented programming language developed by Microsoft that is implemented on the .NET Framework. Previously known as Visual Basic .NET.
2,496 questions
{count} votes

2 additional answers

Sort by: Most helpful
  1. Bob Fischer 71 Reputation points
    2021-12-14T22:20:59.18+00:00

    The behavior is being observed in SQL Express and I cannot duplicate this in SQL Server in development mode. The problem is that I do not understand why this delayed execution of certain commands occurs, which I tried to explain as simply as possible. You can ignore my musing about some possible inadequacy in SQLExpress, but it occurred to me that the Express version may have different behaviors.


  2. Erland Sommarskog 98,636 Reputation points
    2021-12-14T22:52:34.46+00:00

    It is still not clear how you make these observations.

    It could be that some joker has implemented the application to behave differently depending on the edition of SQL Server. Or the edition has nothing do with it, and the differences you see are due to something else.