Unable to add DevOps Repo as Config Server ito my Spring Cloud using HTTP basic authentication.

Sai Pratheek 1 Reputation point
2021-12-15T12:51:56.867+00:00

I've been trying to add my DevOPS repo as a config server to my spring cloud deployed on Azure but its not validating. I tried to clone using the same link with basic HTTP authentication and I was able to do it. I could successfully add github repo as config server but not devops repo.

157896-image.png

Troubleshooting steps I followed:

  1. Tried regenerating new credentials failed.
  2. Created credentials with full access failed.
  3. Tried recreating another azure spring cloud and even another repo, still it failed.
  4. Tried on another account too no result.
  5. Reviewed permissions for repo everything was fine.
  6. Tried cloning locally using same link and credentials success, but couldn't add to Spring Cloud Config Server.

Can anyone check with their accounts and suggest me the solution?

Azure DevTest Labs
Azure DevTest Labs
An Azure service that is used for provisioning development and test environments.
252 questions
Azure Spring Apps
Azure Spring Apps
An Azure platform as a service for running Spring Boot applications at cloud scale. Previously known as Azure Spring Cloud.
104 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. KarishmaTiwari-MSFT 17,247 Reputation points Microsoft Employee
    2021-12-15T12:57:44.217+00:00

    Azure DevOps is currently not supported on Microsoft Q&A. The Azure DevOps team and community are active and answering questions on https://developercommunity.visualstudio.com/spaces/21/index.html
    Please post your question there and the experts will guide you there.

    You can also ask for help here on Stack Overflow: https://stackoverflow.com/questions/tagged/azure-devops

    0 comments No comments