Autodiscover Problem to connect Outlook from Non Domain

Debmallya Sanyal 1 Reputation point
2021-12-15T16:17:37.87+00:00

Hi ,
We are having one issue with outlook autodiscover configuration from non domain system.

We have unidirectional connectivity on port 443 from a desktop to exchange server. We are able to connect successfully through webmail.

But we are facing some issue with autodiscover configuration. It is asking for authentication in outlook but after that it is failing
The following is showing on httpproxy/Autodiscover log on exchange server.

<desktopIP>,<exchange serverIP>,401,,UnauthenticatedRequest,POST,,,,,,,,,356,,,,0,,,0,,0,,0,0,,0,1,0,,,,,,,,,0,1,0,,1,,1,1,,,,BeginRequest=2021-12-15T13:00:29.849Z;CorrelationID=<empty>;ProxyState-Run=None;ProxyState-Complete=CalculateBackEnd;EndRequest=2021-12-15T13:00:29.865Z;,

Please help..

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,208 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Manu Philip 16,901 Reputation points MVP
    2021-12-15T17:38:51.16+00:00

    Do a test on the configuration from the Microsoft test connectivity portal, by selecting 'Use Audodiscover...' This will show you the point at which the connectivity fails like Certificate, DNS records, authentication etc.

    If it looks as an IIS permission issue, the reference documentation can help to correct it is here: https://learn.microsoft.com/en-us/exchange/clients/default-virtual-directory-settings?view=exchserver-2019

    https://testconnectivity.microsoft.com/tests/Ola/input


  2. KyleXu-MSFT 26,196 Reputation points
    2021-12-16T02:47:56.633+00:00

    @Debmallya Sanyal

    Since you could connect to Exchange server from domain-joined computer, we can know this issue is related with the DNS record. The OWA only needs to use the mail.domain.com, but the Outlook client needs to use both "mail.domain.com" and "autodisocver.domain.com".

    If you are using Outlook 2016 and later version, you use command below to create a blank profile

    outlook.exe /pim "No Account"  
    

    The use the "Test E-mail AutoConfiguration" to check the Autodiscover service, make sure it could resolution successfully:
    158093-qa-kyle-10-43-46.png


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.