Linker option not available when trying to add addional libraries in visual studio 2019

Robert Scott 1 Reputation point
2021-12-15T18:16:53+00:00

I'm trying to reference additional libraries in visual studio 2019 but when i right click on the project and go to properties the linker option is not there. Is there something that i didnt install properly when setting up visual studio? What am I missing? Thank you in advance.

-Rob

C++
C++
A high-level, general-purpose programming language, created as an extension of the C programming language, that has object-oriented, generic, and functional features in addition to facilities for low-level memory manipulation.
3,440 questions
{count} votes

3 answers

Sort by: Most helpful
  1. David Lowndes 4,691 Reputation points
    2021-12-15T20:19:21.573+00:00

    That's how it should be - a static library is just a .LIB file with the object code.
    It's the LIB command that "links" (joins) object files into a .LIB.

    0 comments No comments

  2. Minxin Yu 9,361 Reputation points Microsoft Vendor
    2021-12-16T06:53:39.05+00:00

    Hi, @Robert Scott
    Welcome to Microsoft Q&A!

    i think it's a static library.

    You can confirm which project you are using in Properties > General > Configuration Type.
    158107-%E5%B1%8F%E5%B9%95%E6%88%AA%E5%9B%BE-2021-12-16-144840.jpg

    Best regards,

    Minxin Yu


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our [documentation][3] to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  3. Robert Scott 1 Reputation point
    2021-12-16T15:41:57.45+00:00

    Sorry, but i dont think anyone is understanding me. See the picture above how it does not have a link option in the left hand pannel. That is what i was also missing. I installed vcpkg and now it is there and i can link external libraries. Thanks for offering some help though.