One computer insists on having exclusive access to my back-end DB

Brian Hart 21 Reputation points
2021-12-16T11:06:55.29+00:00

As of yesterday morning, one of the five computers in my client's office apparently began locking my Access mapped-drive back end files when we open the relevant local front end file on that computer. Once that computer has the file open, anyone else on another workstation (or I on the server), gets error 3045: "Could not use [path & back-end file name]; file already in use". The converse is also true; if I open the app on a different computer first, the problem computer gets the message when I try to run the app there.

Environment

  1. All workstations are Windows 10 Pro 64-bit running Access 2013 runtime 32-bit with stock Windows Defender (so I do not suspect any interference from AV software here). There are no other connectivity problems or latency to the mapped drive where the BE resides.
  2. The server is Windows 2012 R2 with Office Pro 2013, that is, the full version of Access. All Office installations are 32-bit.
  3. All five computers have their own copies of the three FE's on their local drives.
  4. There are no cross-connections here; each FE is linked to tables in only one of the BE's.
  5. The BE for all three apps are on a server accessed via a mapped drive the same way for all computers.
  6. All three FE files are all .accdr files; the three BE's are all .accdb files.
  7. All three BE files are configured for shared access, not exclusive.
  8. There are sometimes leftover .laccdb files after all stations have closed the app, but not always.

Additional notes

  1. The same thing happens with all three Access applications. So it is not BE/FE or database-specific.
  2. The problem is machine-specific (only one computer) but user-independent; it occurs whether an end user is logged onto the computer or whether I am logged on as domain admin.
  3. If I try to open one of the apps on the problem workstation after it is open on another computer, I get the error 3045.
  4. The converse is also true; if I open it on the problem workstation first, it opens with no problem. But when I then try to open elsewhere, I get that error on the other computer.
  5. But I can open the same apps on multiple other computers concurrently, including the server, with no error.
  6. A couple of times, when there has been a conflict, both users have closed the app, and one of them has left the file lock in place: on the server → compmgmt.msc → Shared Files → look at open files; the BE .accdb file is still listed as open after both computers have closed the app. More often, though, closing the app on both computers clears the file locks.
  7. I also tried, just to prove the point, to put an FE on the server and open it from multiple stations simultaneously. It behaves the same; they can all open it so long as the problem station is not involved. In this case, it lists the FE as the inaccessible file. This is because my apps all open the FE and only link to the BE upon user login. So as soon as I open the same FE, the problem occurs. But here is a bit of a clue: the message is a bit different. When I open an FE on the server from one station, then on the problem station, it says "Could not lock file".

What I have tried:

  1. Compacted/repaired all three BE's
  2. Copied a fresh copy of the three FE files to the problem computer.
  3. Removed & reinstalled Access Runtime from the problem workstation, and rebooted multiple times in the process
  4. Updated Windows & Office & rebooted all workstations and all servers, including the VM that hosts the BE & the physical server

This all points strongly to a problem specific to the computer in question. It is as though there is some registry entry or configuration file on that computer indicating to Access Runtime that it should demand exclusive access to the backend, a setting that does not exist on any of the other computers. But I am not aware of any such setting. I can do very little diagnostics from the affected workstation, since it has only Access runtime. Also because it is runtime, there is no way I know of to explicitly request exclusive access when open a file (by opening the front end that has tables links to the BE).

Or it may be broader than Access, that is, it may be something requiring locks on all files. I am just lost after many hours of troubleshooting this after hours to try to avoid interfering with users' work--and soon it will be morning and they will be back at it again--without me having fixed it yet.

Access Development
Access Development
Access: A family of Microsoft relational database management systems designed for ease of use.Development: The process of researching, productizing, and refining new or existing technologies.
798 questions
0 comments No comments
{count} votes

1 additional answer

Sort by: Most helpful
  1. Brian Hart 21 Reputation points
    2021-12-16T16:54:47.707+00:00

    I halfway expected it to be something brought on by an update, but having done all the Windows & Office updates to multiple computers in my attempts to resolve the issue, with the problem still occurring on only one, I figured I had ruled out different Office or Windows update levels. I did look for recent updates on the faulty computer and one other, but there were so many updates installed there by the time I checked that I had no way of identifying any potential culprits, and I had not gone through computers comparing which ones had which updates.

    But you have undoubtedly identified the issue, so I will assume that I just need to go through the faulty workstation and ferret out & remove the faulty update. Given that this is Access runtime, though, I am not sure the information on reverting to an earlier version will be relevant. This computer has Office Home & Business 2016 (no Access) and Access runtime 2013.

    I will remove/reinstall Access runtime 2013--as I did yesterday, but not run any updates afterwards--as I did yesterday.

    Thank you!

    0 comments No comments