question

don3zo-8641 avatar image
0 Votes"
don3zo-8641 asked MuctaryAbdallah-5936 commented

EWS - 401 Unauthorized, Fails at New Mail Item. 365 Exchange Online

Hello Everyone,

Was wondering if someone could please assist me in figuring out this issue. I am trying to authenticate to:

https://outlook.office365.com/ews/exchange.asmx

However it is not accepting the credentials. It just keeps asking for me to input the credentials after attempting to sign in. After using the connectivity analyzer, it all is successful until it attempts to create a new mail item:

164013-image.png



I have confirmed the following inside 365:

  • MFA is turned off

  • Admin Accounts do not have MFA on

  • Modern and Basic authentication are enabled

  • Credentials are correct (Can login through OWA - outlook.office365.com through browser with no issue)

  • Security defaults are presently turned off

One other thing to note here, is the authenticating account is using the onmicrosoft domain, so any DNS issues should not be present.

If anyone has any ideas, please do let me know and will attempt to fix this thing!



office-exchange-online-itprooffice-exchange-server-connectivity
image.png (122.8 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

KaelYao-MSFT avatar image
0 Votes"
KaelYao-MSFT answered KaelYao-MSFT rolled back

Hi @don3zo-8641

You may use the Basic Auth self-service tool introduced in this link to check if there are some settings blocking basic auth in your tenant:
Basic Authentication and Exchange Online – September 2021 Update

And is this account included in Conditional Access policies?
If yes, please exclude it from the policies and retry.


If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

don3zo-8641 avatar image
1 Vote"
don3zo-8641 answered MuctaryAbdallah-5936 commented

Hello everyone,

This is now resolved. Issue was although Basic Authentication looked like it was turn on at the front end, it actually was not. We had to go through a different method to turn it on through the 365 support option.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello, how did you solve this? I'm having the same issue. details please

0 Votes 0 ·