deployHXCoreVM1Script

Kevin Sand 1 Reputation point
2022-01-16T20:49:07.927+00:00

I'm having a conflict when i try setting up the Perforce – Enhanced Studio Pack it always give me the error: conflict on the part prodhxcorevm1/CustomCommand
Microsoft.Compute/virtualMachines/extensions.

{
"status": "Failed",
"error": {
"code": "VMExtensionProvisioningError",
"message": "VM has reported a failure when processing extension 'CustomCommand'. Error message: \"Enable failed: failed to execute command: command terminated with exit status=5\n[stdout]\n\n[stderr]\n\"\r\n\r\nMore information on troubleshooting is available at https://aka.ms/VMExtensionCSELinuxTroubleshoot "
}
}

I really don't know what i do wrong i follow the instructions provided by preforce. And yet it keeps giving me the same error

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,089 questions
{count} votes

1 answer

Sort by: Most helpful
  1. srbhatta-MSFT 8,546 Reputation points Microsoft Employee
    2022-01-19T05:54:10.897+00:00

    Hi @Kevin Sand ,

    Thank you for reaching out to Microsoft QnA platform.

    I tried searching for the Perforce template and here is something I found - Perforce helix core server.
    As per my understanding, if you are trying to deploy a linux instance from the above template to Azure and facing issues on it, then here is something I would suggest. As this template is not owned by Microsoft and is available AS IS, I would please request you to reach out to the product vendor to get some better understanding on why the issue is happening.

    Else, if in case you are trying to add a custom script extension to an existing VM and it is failing you could try following the below remediation steps.

    1. Please check the state of the Guest Agent (GA) of the VM. For any extension to be able to run on an existing VM, the GA should be in ready state. If the GA is not in ready state, try to SSH into the VM and check the GA status with the following command - systemctl status walinuxagent.service. If the service does not exist, you will have to install the GA.
    2. If only the custom script extension is failing, then you could try to remove the extension and re-run the template.
    3. There are some additional logs you can take a look at to help you in these kind of scenarios. You can try looking at the custom script extension log under /var/log/azure .
      You could also check the if the extension ran or failed under the Linux Agent log under /var/log/waagent.log

    Reference links:
    General troubleshooting steps
    Custom script extension on Linux virtual machines

    Please let me know if the issue is separate from what my understanding is.
    Will wait to hear back from you on this. If any of the above helps you, please 'Accept as answer'.

    1 person found this answer helpful.
    0 comments No comments